Bug 489738 - broken saned (non-root) authorization to access scanner device on server
broken saned (non-root) authorization to access scanner device on server
Product: Fedora
Classification: Fedora
Component: PolicyKit (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-03-11 11:59 EDT by Eric Herget
Modified: 2013-03-05 22:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-18 04:00:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Eric Herget 2009-03-11 11:59:51 EDT
Description of problem:
I can't get access to my scanner device as non-root user using "proper" PolicyKit/ConsoleKit authorizations.  A possible issue that affects this problem is that I run at init level 5 (gui), but gdm doesn't start because of a separate using-vesa-driver-for-my-radeon-graphics-card issue.  I filed this under PolicyKit, but ConsoleKit might have some relevance, too.  The purpose of all my effort is to get saned authorization to access my scanner as a non-root user so I set up network scanning support.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Get scanner setup so that `scanimage -L` as root user reports scanner.
2. `scanimage -L` as non-root (eherget) user doesn't find scanner.
3. Issue any/all of the following commands:
polkit-action --set-defaults-inactive org.freedesktop.policykit.grant yes
polkit-action --set-defaults-any org.freedesktop.policykit.grant yes
polkit-auth --user eherget --grant org.freedesktop.hal.device-access.scanner
4. reboot after issuing any/all the above commands
5. `scanimage -L` as eherget (non-root) still doesn't find scanner, while root user can
6. changing ownership on the usb device (in my case /dev/bus/usb/002/002 to user 'eherget' results in `scanimage -L` working for user eherget.  Oddly, changing group ownership to my user's primary group while leaving the device owned by user root still prevents `scanimage -L` from finding the scanner.  Permissions on the device are "crw-rw-r--+". 
Actual results:
`scanimage -L` can't find/access the scanner device as non-root user without changing actual ownership on the device.

Expected results:
users authorized by the various polkit-action and polkit-auth commands should have access to the scanner device (yes, I rebooted after all attempts to change authorization with the polkit commands).  Ultimately, only the polkit-auth command should be necessary to enable a non-root user on a headless server system to access a scanner device.

Additional info:
As I mentioned, I have init level set to 5, but gdm doesn't start because of a separate issue.  I would hope this has no bearing on this issue, but some of the issues I was able to find while researching this on the net might imply otherwise.  On a true headless server (init level 3) ConsoleKit should have no relevance as ck-xinit-session should not be getting executed.
Comment 1 Bug Zapper 2009-11-18 04:54:24 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 2 Bug Zapper 2009-12-18 04:00:02 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.