Bug 489739 - Mar 10 update killed NetworkManager-gnome-0.7.0.99-3.fc10.x86_64 functionality
Mar 10 update killed NetworkManager-gnome-0.7.0.99-3.fc10.x86_64 functionality
Status: CLOSED DUPLICATE of bug 489398
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 12:00 EDT by Ben Behnam
Modified: 2009-03-11 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 12:52:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Behnam 2009-03-11 12:00:07 EDT
Description of problem: 

Updates of March 10th 2008 stop network manager from getting an IP address.


Version-Release number of selected component (if applicable):

NetworkManager-gnome-0.7.0.99-3


Yum log states that:

*** Begin log ***

Mar 10 23:04:01 Updated: 1:NetworkManager-gnome-0.7.0.99-3.fc10.x86_64

*** End Log ***

NetworkManager-gnome-0.7.0.99-3 was updated.  Network manager stopped working after that.  Was unable to find any error related to it in /var/log directory.  It just stopped working; as in no Ip address and no more network.


How reproducible:

Did not do anything special.  I keep my system up to date.  I simply applied the updates of March 10th and it broke NetworkManager.  


Steps to Reproduce:
1. Log on to system
2. Wait for system update to inform you of available updates
3. Apply updates
4. Reboot system

  
Actual results:

No more network connection.  Eth0 has no ip address.


Expected results:

Expected to have a network connection after update process.


Additional info:

As a workaround I stopped the network manager service, and enabled the network adapter by going to:

System --> Administration --> Network --> Double click on Eth0 profile:

Then:
  - deselect "Controlled by NetworkManager"
  - Select "Activate Device When Computer Starts"
  - Click Ok.

File --> "Save"

Reboot and you will have networking now.

P.S.  

I know all this rebooting is not necessary; but, I have to know it will work when I'm not around.  The other users are not able to troubleshoot.  They just want to turn the system on and be able to use it.  This is a desktop not a server, so we shut it down when we are not using it.
Comment 1 Dan Williams 2009-03-11 12:52:47 EDT

*** This bug has been marked as a duplicate of bug 489398 ***

Note You need to log in before you can comment on or make changes to this bug.