Bug 489776 - Clicking in an image in GIMP causes X to crash
Clicking in an image in GIMP causes X to crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 15:31 EDT by Mace Moneta
Modified: 2009-07-05 06:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 13:58:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (76.01 KB, text/plain)
2009-03-11 15:31 EDT, Mace Moneta
no flags Details

  None (edit)
Description Mace Moneta 2009-03-11 15:31:15 EDT
Created attachment 334853 [details]
Xorg.0.log

Description of problem:

I opened a jpg in GIMP, selected the rectangle selection tool, and clicked in the image to start the selection.  X crashed.  Re-login, retry, X crash.

Version-Release number of selected component (if applicable):

gimp-2.6.5-3.fc11.x86_64
gimp-libs-2.6.5-3.fc11.x86_64
gimp-lqr-plugin-0.4.0.4-3.fc11.x86_64
gimp-resynthesizer-0.15-4.fc11.x86_64

kernel-2.6.29-0.218.rc7.git2.fc11.x86_64

mesa-dri-drivers-7.3-12.fc11.i586
mesa-dri-drivers-7.3-12.fc11.x86_64
mesa-libGL-7.3-12.fc11.i586
mesa-libGL-7.3-12.fc11.x86_64
mesa-libGL-devel-7.3-12.fc11.x86_64
mesa-libGLU-7.3-12.fc11.i586
mesa-libGLU-7.3-12.fc11.x86_64
mesa-libGLU-devel-7.3-12.fc11.x86_64

xorg-x11-apps-7.3-7.fc11.x86_64
xorg-x11-drivers-7.3-11.fc11.x86_64
xorg-x11-drv-evdev-2.2.0-1.fc11.x86_64
xorg-x11-drv-intel-2.6.0-14.fc11.i586
xorg-x11-drv-intel-2.6.0-14.fc11.x86_64
xorg-x11-drv-keyboard-1.3.2-2.fc11.x86_64
xorg-x11-drv-mouse-1.4.0-2.fc11.x86_64
xorg-x11-server-common-1.6.0-9.fc11.x86_64
xorg-x11-server-utils-7.4-7.fc11.x86_64
xorg-x11-server-Xorg-1.6.0-9.fc11.x86_64
xorg-x11-util-macros-1.2.1-2.fc11.noarch
xorg-x11-utils-7.4-4.fc11.x86_64

How reproducible:

Always

Steps to Reproduce:
1.Open an image in GIMP
2.Select the rectangular selection tool
3.Try to select an area of the image
  
Actual results:

Boom

Expected results:

A selected portion of the image

Additional info: Xorg log attached with traceback
Comment 1 Matěj Cepl 2009-03-23 18:32:57 EDT
This is pretty minimalistic backtrace:

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e9dc6]
1: /usr/bin/Xorg(xf86SigHandler+0x6f) [0x47debf]
2: /lib64/libc.so.6 [0x306c8332f0]

Fatal server error:
Caught signal 11.  Server aborting
Comment 2 Mace Moneta 2009-03-28 15:55:46 EDT
Since I couldn't use GIMP, I tried Inkscape.  Same problem; click in an image, and X crashes:

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e9976]
1: /usr/bin/Xorg(xf86SigHandler+0x6f) [0x47ddaf]
2: /lib64/libc.so.6 [0x306c8332f0]

Fatal server error:
Caught signal 11.  Server aborting

Current software versions:

gimp-2.6.5-4.fc11.x86_64
gimp-libs-2.6.5-4.fc11.x86_64
gimp-lqr-plugin-0.4.0.4-3.fc11.x86_64
gimp-resynthesizer-0.15-4.fc11.x86_64

kernel-2.6.29-9.fc11.x86_64

mesa-dri-drivers-7.5-0.4.fc11.i586
mesa-dri-drivers-7.5-0.4.fc11.x86_64
mesa-libGL-7.5-0.4.fc11.i586
mesa-libGL-7.5-0.4.fc11.x86_64
mesa-libGL-devel-7.5-0.4.fc11.x86_64
mesa-libGLU-7.5-0.4.fc11.i586
mesa-libGLU-7.5-0.4.fc11.x86_64
mesa-libGLU-devel-7.5-0.4.fc11.x86_64

xorg-x11-drv-intel-2.6.99.902-1.fc11.x86_64
Comment 3 Mace Moneta 2009-03-31 18:59:12 EDT
I just wanted to point out that if I enable kms and UXA, the problem does not occur.  UXA isn't usable yet (lots of redraw and corruption issues), but it does fix this problem.
Comment 4 Michal Nowak 2009-04-06 11:03:22 EDT
Same here but on nvidia graphics, switching the component to general Xorg. Crash happens for nv, vesa and nouveau.

With nouveau I can see this msgs in console:

[drm] nouveau_fifo_free: freeing fifo 1
[drm] nouveau_fifo_free: freeing fifo 0
Comment 5 Michal Nowak 2009-04-06 11:29:17 EDT
When debugging the core I got this

BFD: Warning: /var/cache/abrt/ccpp-1239031295-10052/binary_data1 is truncated: expected core file size >= 61943808, found: 122880.

:/. All cores from this crash are like this.
Comment 6 Mace Moneta 2009-04-08 09:31:41 EDT
For my graphics card (G45/X4500HD), the problem is resolved in rawhide by running with KMS and UXA (no xorg.conf), which is now usable as long as you don't run Compiz:

kernel-2.6.29.1-52.fc11.x86_64
libdrm-2.4.5-4.fc11.i586
libdrm-2.4.5-4.fc11.x86_64
mesa-dri-drivers-7.5-0.7.fc11.i586
mesa-dri-drivers-7.5-0.7.fc11.x86_64
mesa-libGL-7.5-0.7.fc11.i586
mesa-libGL-7.5-0.7.fc11.x86_64
mesa-libGLU-7.5-0.7.fc11.i586
mesa-libGLU-7.5-0.7.fc11.x86_64
xorg-x11-drv-intel-2.6.99.902-2.fc11.x86_64
Comment 7 Adam Jackson 2009-05-08 13:58:26 EDT
Closing as per comment #6.
Comment 8 Alex Butcher 2009-07-05 06:43:33 EDT
Adam: what about those of us who aren't using the same video cards as Mace Moneta?

Note You need to log in before you can comment on or make changes to this bug.