Bug 489789 - CSP CP to Product relationships are not accurate
CSP CP to Product relationships are not accurate
Status: CLOSED WONTFIX
Product: JBoss Customer Support Portal
Classification: Retired
Component: SEP (Show other bugs)
GovernanceBoard
All All
medium Severity medium
: ---
: ---
Assigned To: JBoss CSP Bug Watch List
https://jira.jboss.org/jira/browse/JB...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 16:47 EDT by Tom Mirc
Modified: 2011-01-31 12:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-31 12:40:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Mirc 2009-03-11 16:47:29 EDT
Description of problem:

For example in the CSP feed the 4.3.0.GA_CP01 patch says that it is applicable to EAP instances with version 4.3.0.GA_CP01, when in fact it should say 4.3.0.GA. There are many instances of this in the 4.3 line of CPs and all of them need to be reviewed.

Example bad piece of feed

    <dc:subject>JBoss EAP 4.3.0.GA_CP01</dc:subject>
    <dc:date>2008-05-08T16:21:Z</dc:date>
    <jbn:creator/>
    <jbn:distributionStatus>AVAILABLE</jbn:distributionStatus>
    <jbn:licenseName/>
    <jbn:licenseVersion/>
    <jbn:type>BUGFIX</jbn:type>
    <jbn:products>
      <jbn:product jbn:jonResourceType="JBoss 4.0"
        jbn:jonResourceVersion="4.3.0.GA_CP01"
        jbn:productName="Application Platform"
        jbn:productVersion="4.3.0.GA_CP01" rdf:about="https://support.redhat.com/jbossnetwork/rss/product#SOFT-10260">Application Platform; 4.3.0.GA_CP01</jbn:product>
    </jbn:products>


Version-Release number of selected component (if applicable):


How reproducible:

This is a data error that will persist in the RSS feed to JON until corrected.

Steps to Reproduce:

1. Review JON RSS response https://support.redhat.com/jbossnetwork/restricted/feed/software.html?product=all&downloadType=all&flavor=rss&version=&jonVersion=2.0

2. JON resource version and product version for 4.3.0.GA_CP01 will be 4.3.0.GA_CP01.  They need to be different, CP-01 does not replace itself.

  
Actual results:


Expected results:


Additional info:
Comment 1 Grant Shipley 2009-03-12 14:56:35 EDT
Approved.  Moving to XPlanner backlog.
Comment 2 Tom Mirc 2009-03-12 17:05:39 EDT
Note that Issue-Tracker #271224 can be tackled as part of the fix for this release.
Comment 3 John Sanda 2009-03-23 16:13:00 EDT
I looked at the I-T ticket. I think this will have to be addressed separately. SEP provides the ability to delete repositories, but it does not provide the ability to delete software entries. Each version in the version pick list directly corresponds to a software entry in SEP (or more specifically a row in the software table). So removing a version from the version pick list equates to removing a software entry. Presently, that would have to be done with a SQL script.

There are a couple other things you consider adding separate tickets for in bugzilla. 1) Add the capability to delete software rows in SEP. 2) Update the business logic for the versions pick list so that it does not include versions for which there is no content.
Comment 4 Tom Mirc 2009-03-23 17:40:56 EDT
Pending additional data from ccrouch: Email below

"We believe that we clearly understand the issue, in that the CP for 4.3.0.GA can not be deployed via JON because there is an improper mapping of CP_01 to 4.3.0 GA--4.3.0 GA is not currently defined in the RSS feed.

We need to know which of the jbn: product fields in the RSS need to be changed?  Which field defines the base version and which field defines the replacement?  If it would be easier, you could update the JIRA, and I will pick up the correspondence from there."
Comment 5 Tom Mirc 2009-03-26 17:19:08 EDT
The improper mapping, which currently exists, is from CP01 to jbn:jonResourceVersion="4.3.0.GA_CP01"
The correct mapping is from CP01 to jbn:jonResourceVersion="4.3.0.GA"

>
> We need to know which of the jbn: product fields in the RSS need to be
> changed?  Which field defines the base version and which field defines
> the replacement?  

Look at https://support.redhat.com/support-portal/restricted/software/repositoryDetails.html?id=788 (4.3 CP04) for an example:

The Products field holds:
SOFT-0221,SOFT-10260,SOFT-10284,SOFT-10290

Where for example SOFT-10284 maps to https://support.redhat.com/support-portal/restricted/software/softwareDetails.html?id=284 (4.3.0.GA_CP02)
Those are the things which  generate the  <jbn:product> elements.

So basically what you need to do is determine the SOFT-NNNNN mappings to product versions, then update the appropriate repository details for each patch so they have the correct values of SOFT-NNNNN in the "Products" field.

Cheers
Charles
Comment 6 John Sanda 2009-03-31 16:44:17 EDT
I spoke with Charles Crouch to get a better understanding of the issue. CPs apply to previous CPs up to and including the base version. So a bug fix for 4.3.0.GA_CP04 applied to 4.3.0.GA_CP03, 4.3.0.GA_CP02, 4.3.0.GA_CP01, and 4.3.0.GA.

I looked at one 4.3.0.GA_CP02 EAP patch (there may be others) with Charles that is mapped to Application Server 4.2.0. This is wrong for two reason as explained by Charles. First, EAP patches are not applied to App Server. Secondly, a patch from the 4.3 line cannot be applied to the 4.2.x line. It could break the installation. We probably want to open a separate bug to perform an audit of what is mapped to Application Server downloads. We'll need to do the same for Developer Subscription. I see that some of the EAP patches are mapped to it, and I do not know if that is correct.

Lastly, if a patch does not provide automated instructions, JBoss ON altogether ignores the patch since it applies the patches using the automated instructions.
Comment 7 David Spalding 2011-01-31 12:40:12 EST
Bugs are no longer tracked under this classification. CSP is now monitored in 
Other | Customer Portal | Integrated app: JBoss CSP. 

Please refile any current defect records or RFEs under the current 
classification.
Comment 8 David Spalding 2011-01-31 12:48:04 EST
Bugs are no longer tracked under this classification. CSP is now monitored in 
Other | Customer Portal | Integrated app: JBoss CSP. 

Please refile any current defect records or RFEs under the current 
classification.

Note You need to log in before you can comment on or make changes to this bug.