This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 489805 - a recent Fedora 10 upgrade breaks nvidia drivers
a recent Fedora 10 upgrade breaks nvidia drivers
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 18:40 EDT by ewc
Modified: 2009-03-11 19:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 19:48:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug report produced by nvidia-bug-report.sh (137.12 KB, application/octet-stream)
2009-03-11 18:40 EDT, ewc
no flags Details

  None (edit)
Description ewc 2009-03-11 18:40:21 EDT
Created attachment 334867 [details]
bug report produced by nvidia-bug-report.sh

Description of problem:
A recent (somewhere around 06 March 2009) bug-fix and/or other upgrade (sorry, can't figure out which one) causes applications needing: (1) 3-D (openGL) on a desktop machine, and: (2) 3-D and acceleration on a laptop, to no longer work with: (1) nvidia 173.14.15 driver (GeForceFX5200 card) and: (2) 96.43.09 driver (GeForce4 card), respectively. The result on desktop with 173.14.15 is that some (i.e. NVIZ in GRASS-GIS, using tcl/tk) applications requiring openGL won't start, however, IBM's openDX runs fine. The result on laptop with 96.43.09 is that X-server shuts down and restarts. A temporary fix is to remove (rename) xorg.conf file to allow default video driver to run. This is fine for GRASS-GIS, but not for applications like tux-racer or google-earth.


Version-Release number of selected component (if applicable):
Most recent stock releases of all packages available from Fedora repo. with all recent upgrades (except most recent kernel upgrades) applied to both machines. Running x86 kernel 2.6.27.12-170.2.5.fc10.i686 on both machines.


How reproducible:
every time, both machines, since applying bug-fix and other upgrades on or around 06 March 2009, and continues with upgrades available/applied as at 10 March 2009. Upgrades are all "stock" from Fedora repo. using upgrade agent.

NVIZ now runs fine using default video driver. Applications requiring video acceleration obviously don't run.


Steps to Reproduce: (on desktop)
1. attempt to start NVIZ in GRASS-GIS either from display button or GIS-manager drop-down menu and NVIZ startup GUI
2.
3.

Steps to Reproduce: (on laptop)
1. attempt to start extreme tux racer from either menu or from console
2. attempt to start google-earth from either menu or from console
3.


Actual results:
(1) desktop: NVIZ sub-windows flash on-off with no error messages when clicking on disply button; NVIZ sub-windows flash on-off with error messages in output window when trying to start NVIZ from drop-down menu and NVIZ startup GUI. GRASS continues to run fine.

(2) laptop: On trying to start tux-racer, X-server shuts down (screen goes black) immediately, then log-on required for X-server to restart. On trying to start google-earth, splash screen comes up, then X-server shuts down (as with tux-racer). 

Expected results:
NVIZ to cycle through startup process and run. Tux racer to bring up starting window. Google earth to bring up window with globe.

Additional info:
As noted, NVIZ problem resolved temporarily by removing xorg.conf so default video driver can run. But this is not a solution where video acceleration is needed, therefore, have not removed xorg.conf from laptop to test things any further, as both are business machines, with desktop more mission-critical.

Attached is nvidia-bug-report generated following problem.
Comment 1 Matěj Cepl 2009-03-11 19:48:02 EDT
Thanks for the report. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides indirect customer support via an online web based support forum.  Nvidia monitors these web forums for commonly reported problems and passes them on to Nvidia engineers for investigation.  Once they've isolated a particular problem, it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have experienced the particular problem may be able to assist.  If there is a real bug occuring, Nvidia will be able to determine this, and will likely resolve the issue in a future driver update for the operating system releases that they officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring technical support may also find the various X.Org, XFree86, and Red Hat mailing lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Note You need to log in before you can comment on or make changes to this bug.