Bug 489825 - Errors in perl-Newt: exported flag issue and documentation fixes
Errors in perl-Newt: exported flag issue and documentation fixes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Newt (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 21:35 EDT by Joe Ogulin
Modified: 2009-05-28 11:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-28 11:42:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to remove additional reference of NEWT_FLAG_NOSCROLL (327 bytes, patch)
2009-03-11 21:35 EDT, Joe Ogulin
no flags Details | Diff
Patch to correct documentation error and misspelling (535 bytes, patch)
2009-03-11 21:36 EDT, Joe Ogulin
no flags Details | Diff
Modified spec file (4.25 KB, text/plain)
2009-03-11 21:37 EDT, Joe Ogulin
no flags Details

  None (edit)
Description Joe Ogulin 2009-03-11 21:35:42 EDT
Created attachment 334882 [details]
Patch to remove additional reference of NEWT_FLAG_NOSCROLL

Description of problem:
In a perl script 

use Newt qw(:flags);

produces:
"NEWT_FLAG_NOSCROLL" is not exported by the Newt module

Also, if you look at "man Newt" you will see a misspelling in the middle:
       Drawing panels instead uf running them

And this at the end:

POD ERRORS
       Hey! The above document had some coding errors, which are explained below:

       Around line 860:
           You forgot a ’=back’ before ’=head1’



Version-Release number of selected component (if applicable):
1.08-21

How reproducible:
Install perl-Newt, use :flags as part of the list of things.

Actual results:
See above

Expected results:
No errors; no misspellings

Additional info:
Attached are two patch files to correct the problems along with a modified spec file.  Since the newt-perl-1.08-debian.patch removed the one NEWT_FLAG_NOSCROLL, I am assuming that it should be removed.  Otherwise, the export patch should be removed and the debian patch modified to leave NEWT_FLAG_NOSCROLL in place.
Comment 1 Joe Ogulin 2009-03-11 21:36:35 EDT
Created attachment 334883 [details]
Patch to correct documentation error and misspelling
Comment 2 Joe Ogulin 2009-03-11 21:37:07 EDT
Created attachment 334884 [details]
Modified spec file
Comment 3 Joe Orton 2009-05-28 11:42:50 EDT
Thanks for the patches!  Built for Raw Hide:

http://koji.fedoraproject.org/koji/buildinfo?buildID=103937

Note You need to log in before you can comment on or make changes to this bug.