Bug 489842 - lsattr and chattr exit with 0 even if the file does not exist
lsattr and chattr exit with 0 even if the file does not exist
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Sandeen
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 04:31 EDT by Milos Malik
Modified: 2011-07-21 08:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: e2fsprogs-1.39-27.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 08:35:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2009-03-12 04:31:03 EDT
Description of problem:
If somebody runs lsattr or chattr on non-existent file, the exit code is always zero.

Version-Release number of selected component (if applicable):
e2fsprogs-1.39-20.el5

How reproducible:
always

Steps to Reproduce:
# ls output.txt
ls: output.txt: No such file or directory
# echo $?
2
# lsattr output.txt
lsattr: No such file or directory while trying to stat output.txt
# echo $?
0
# chattr +d output.txt
chattr: No such file or directory while trying to stat output.txt
# echo $?
0

Actual results:
both utilities exit with zero code

Expected results:
both utilities exit with non-zero code

Additional info:
Comment 1 Milos Malik 2009-03-12 04:34:52 EDT
The e2fsprogs-1.35-12.17.el4 package in RHEL-4.7 is also affected.
Comment 2 Eric Sandeen 2009-03-17 16:37:15 EDT
this problem exists upstream as well.
Comment 4 Eric Sandeen 2009-06-24 16:11:14 EDT
Sorry this didn't make it for 5.4; setting 5.5 ?

the patches are all upstream now.

Thanks,
-Eric
Comment 6 RHEL Product and Program Management 2009-11-06 14:24:24 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 RHEL Product and Program Management 2010-08-09 15:44:52 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 Eric Sandeen 2011-01-27 19:08:00 EST
Built & tagged in e2fsprogs-1.39-27.el5
Comment 13 errata-xmlrpc 2011-07-21 08:35:51 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1080.html

Note You need to log in before you can comment on or make changes to this bug.