Bug 489876 - kernel option dom0_mem doesn't work
kernel option dom0_mem doesn't work
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Rik van Riel
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 09:17 EDT by Daniel Mach
Modified: 2009-03-17 08:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 08:19:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Mach 2009-03-12 09:17:43 EDT
I have this kernel option in grub.conf: dom0_mem=512m
After boot, dom0 allocates all memory instead of 512M.

It used to work in rhel-5.2.

As a workaround, I have to call:
$ xm mem-set Domain-0 512
Comment 1 RHEL Product and Program Management 2009-03-12 09:21:42 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 3 Chris Lalancette 2009-03-12 10:09:19 EDT
Can you please attach the full output of the grub.conf entry that you think should work, but doesn't?

Thanks,
Chris Lalancette
Comment 4 Chris Lalancette 2009-03-12 10:16:55 EDT
FYI: on my system, the following does indeed do the right thing:

title Red Hat Enterprise Linux Server (2.6.18-134.el5virttest12xen)
	root (hd0,0)
	kernel /xen.gz-2.6.18-134.el5virttest12 dom0_mem=512M
	module /vmlinuz-2.6.18-134.el5virttest12xen ro root=/dev/VolGroup02/LogVol00
	module /initrd-2.6.18-134.el5virttest12xen.img

# xm list (right after boot)
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0      512     4 r-----     27.8

Chris Lalancette
Comment 5 Daniel Mach 2009-03-17 08:19:58 EDT
Chris,
sorry for confusion,
I had the dom0_mem as a kernel (not xen) option in grub.conf.
Now everything works fine.

Since I didn't have xen dom0 ballooning problems for a long time so I thought that the "not enough memory" problems during `xm create` were caused by a kernel upgrade and therefore a regression.

Looks like I was just lucky and didn't hit this problem since 5.2 was released until now.

thanks,
- daniel

Note You need to log in before you can comment on or make changes to this bug.