Bug 489918 - DeviceException: Could not find device for path /dev/sdb
DeviceException: Could not find device for path /dev/sdb
Status: CLOSED DUPLICATE of bug 488800
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:2b203f5e3ee511573...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 11:12 EDT by James Laska
Modified: 2013-09-02 02:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-12 11:19:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (74.21 KB, text/plain)
2009-03-12 11:12 EDT, James Laska
no flags Details
udevadm info --export-db (100.59 KB, text/plain)
2009-03-12 11:36 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (69.77 KB, text/plain)
2009-03-16 18:57 EDT, Matthieu Araman
no flags Details

  None (edit)
Description James Laska 2009-03-12 11:12:54 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.28 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/device.py", line 48, in __init__
    self.__device = _ped.device_get(path)
  File "/usr/lib/anaconda/storage/devices.py", line 671, in __init__
    self.partedDevice = parted.Device(path=self.path)
  File "/usr/lib/anaconda/storage/devicetree.py", line 980, in addUdevDevice
    initcb=cb)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1272, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 221, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 64, in storageInitialize
    anaconda.id.storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
DeviceException: Could not find device for path /dev/sdb
Comment 1 James Laska 2009-03-12 11:12:58 EDT
Created attachment 334946 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-03-12 11:19:05 EDT

*** This bug has been marked as a duplicate of bug 488800 ***
Comment 3 James Laska 2009-03-12 11:36:43 EDT
Created attachment 334952 [details]
udevadm info --export-db
Comment 4 Matthieu Araman 2009-03-16 18:57:15 EDT
Created attachment 335448 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.