Bug 489934 - Modifying system base software channel: no default field highlighted if no base chan used, can ISE.
Modifying system base software channel: no default field highlighted if no b...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Corey Welton
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-03-12 11:43 EDT by Corey Welton
Modified: 2009-09-10 16:34 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:34:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2009-03-12 11:43:20 EDT
Description of problem:
If a system is subscribed to a base software channel, and user goes to $system > Software > Software Channels, this channel is highlighted by default in the "Base Software Channel" listbox.

However, if system is not subscribed to a base channel, nothing is highlighted.  Hitting the "Confirm" button in this state results in ISE.

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090306.2-i386.iso

How reproducible:
Every time


Steps to Reproduce:

Prerequisite -
* Assure you have one or more standard base channels synced
* Assure you have one or more systems registered 

1.  Navigate to $system > Software > Software Channels
2.  In the "Base Software Channel" listbox, note that your current base channel /is/ highlighted.
3.  select "(none, disable service)" and hit "Confirm"
4.  Click "Modify Base Software Channel" on ensuing page.
5.  After being returned to the "Software Channel" page, observe the "Base Software Channel" listbox.
6.  Click the "Confirm" button.

Actual results:

ISE

Expected results:

No ISE, but this is probably occurring due to a null value being submitted.  

The real issue here is that "(none, disable service)" should probably be highlighted by default if the system indeed has no base channel.  This would avoid the possibility of submitting a null value.

Additional info:

Note that this seems to be the only way I can find to actually "Confirm" without /something/ being selected.  That's why it's more important to simply assure something is always selected, versus trying to debug an ISE which is probably simply due to a null submit.
Comment 1 Justin Sherrill 2009-03-17 16:14:46 EDT
good catch corey :}



commit	9705b42817fb8fc63436b69d013759872284fa3f
tree	15efeb7f39ebf8de7214d01312857297a8cb4365	tree | snapshot
parent	10aa84f166102be39fbc3e3c310a6e85725b165d	commit | diff
Comment 2 Corey Welton 2009-04-08 23:20:46 EDT
QA Verified.  If no base channel, then "(none, disable service)" is selected by default.  I can't seem to find a way to 'unselect' everything, so I think we're good here, wrt avoiding the possibility of any ISEs.
Comment 3 Milan Zázrivec 2009-08-13 05:30:28 EDT
Verified in stage -> RELEASE_PENDING
Comment 4 Brandon Perkins 2009-09-10 16:34:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.