Bug 489952 - i845G, flickering between Plymouth and GDM
i845G, flickering between Plymouth and GDM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 12:49 EDT by Jason Long
Modified: 2009-05-20 14:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 14:25:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg log file (46.53 KB, text/plain)
2009-03-12 12:52 EDT, Jason Long
no flags Details
output of dmesg (29.02 KB, text/plain)
2009-03-12 12:53 EDT, Jason Long
no flags Details

  None (edit)
Description Jason Long 2009-03-12 12:49:32 EDT
Description of problem:

While testing
https://fedoraproject.org/wiki/QA:Testcase_intelvideo_kms,

Modesetting is working, but there is a "flickering" between Plymouth's "progress screen" and when GDM appears.

Basically, after seeing the Fedora splash screen for half a minute or so, the screen goes completely black for approx. 20 seconds, and then the screen changes to a blue background and GDM appears.

I am using the "fade-in" Plymouth plugin, though it seems to behave the same for other plugins as well.


Version-Release number of selected component (if applicable):

xorg-x11-drv-intel-2.6.0-14.fc11.i586


How reproducible:

every time


Steps to Reproduce:
1. start up the system
  

Expected results:
No flickering or mode changes should occur from initrd right through to GDM


Additional info:

I will attach an Xorg.log file in a moment.
Comment 1 Jason Long 2009-03-12 12:52:45 EDT
Created attachment 334966 [details]
Xorg log file

attaching an Xorg.log file, not sure if it's helpful.

Also, my "Smolt" hardware profile can be found here:
http://www.smolts.org/client/show/pub_e5adecb3-9df6-4355-9dfc-a5622c85dc7f
Comment 2 Jason Long 2009-03-12 12:53:51 EDT
Created attachment 334967 [details]
output of dmesg

Also, here's the output of `dmesg'.
Comment 3 Jason Long 2009-05-20 10:59:13 EDT
This bug is no longer occurring in latest Rawhide. The transition is quite smooth.

(still no mouse cursor, but that's a separate issue).

So this bug can be closed, thanks.
Comment 4 Kristian Høgsberg 2009-05-20 14:25:20 EDT
Thanks, good news.  We might have a fix for the missing cursors soon too.

Note You need to log in before you can comment on or make changes to this bug.