Bug 489959 - Multihead on i855 shuts-down displays depending on you you arrange them (Top/Bottom)
Multihead on i855 shuts-down displays depending on you you arrange them (Top/...
Status: CLOSED DUPLICATE of bug 489923
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 13:20 EDT by Mark Watts
Modified: 2009-04-06 19:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 19:12:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (173.29 KB, text/plain)
2009-03-31 11:50 EDT, Ales Zelinka
no flags Details
Xorg.0.log after boot - dual-head (73.51 KB, text/plain)
2009-04-03 08:25 EDT, Mark Watts
no flags Details
Xorg.0.log after unmirroring the screens - dual-head (103.94 KB, text/plain)
2009-04-03 08:26 EDT, Mark Watts
no flags Details
Xorg.0.log after stacking the external screen above the internal one - dual-head (185.46 KB, text/plain)
2009-04-03 08:27 EDT, Mark Watts
no flags Details

  None (edit)
Description Mark Watts 2009-03-12 13:20:00 EDT
Using the Rawhide LiveCD iso for the Intel Driver Test Day.

Hardware: http://www.smolts.org/client/show/pub_147a1a2f-5adb-4d82-8a2a-fdd35783929b

System boots into X, mirroring the display onto a 1600x1200 display.
Both laptop and external display get set to 1024x768 since this is the highest common resolution.
Un-mirroring the displays in gnome-display-preoperties works - I get a dual-width 2048x768 desktop.
I can re-arrange this to have either screen on the left.

When arranging the displays top/bottom the following happens:

External = Top, Laptop = Bottom
Laptop display is shut off and does not come back on when you "revert" the configuration.
Attempting to re-mirror the screens does not help.
Restarting X via logout *does* re-mirror the screens.

External = Bottom, Laptop = Top
Laptop display is shut off.
Reverting the configuration then shuts the external display off too.
Restarting X via logout *may* revert to mirroring, but since I can't see X anymore, I'm unable to verify.
Comment 1 Adam Williamson 2009-03-12 13:34:58 EDT
This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Matěj Cepl 2009-03-30 07:59:51 EDT
(In reply to comment #1)
> This bug has been triaged

Sorry, but this bug has not been properly triaged. Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Adam Williamson 2009-03-30 15:53:37 EDT
Matej, please don't just regurgitate the same stock text without reading the original report.

"Using the Rawhide LiveCD iso for the Intel Driver Test Day"

hence your second block of text is entirely useless, because he's running a *live CD*, of course there's no xorg.conf.

/var/log/Xorg.0.log is generally entirely unhelpful in cases where RandR is what's misbehaving, in my experience.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Matěj Cepl 2009-03-30 17:26:51 EDT
Of course, Adam is right ... there is no /var/log/Xorg.0.log for LiveCD. Do you have anything helpful in /tmp when running installation. Or have you already installed and you don't to try again to produce logs (which would be very understandable)?

If you can switch to Alt+F2 while running installation program, you may dig installation logs and get store them somewhere using network, USB storage drive, or stuff of that sort. If you can do it, please attach this log to this bug as uncompressed attachment to this bug.

Thank you
Comment 6 Adam Williamson 2009-03-30 18:41:49 EDT
you do get /var/log/Xorg.0.log on the live CD, it's just that I doubt it'd be particularly useful in this case - but by all means attach it.

It's xorg.conf that definitely wouldn't have been involved, since each time you boot the live CD, it's a clean boot of a filesystem which definitely doesn't contain one.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Ales Zelinka 2009-03-31 11:49:29 EDT
Happens to me too (on Intel GM965/GL960).

I can un-mirror and then rearrange from left to right, but once I place one of the displays on top, the one at the bottom goes off (no matter which one is it).

Similar issue as described here:
https://bugzilla.redhat.com/show_bug.cgi?id=489923


Seems like the first time displays are un-mirrored, a virtual screen is created. And if I manage to keep my displays in it, everything if fine. But once I put a part of a display out of it (either by rearranging or rotating), the trespassing display is switched off (well, xorg apparently thinks it still work, but the screen is blank, kinda like when a wrong mode is sent to it).


No xorg.conf, log attached.
xorg-x11-server-Xorg-1.6.0-15.fc11.x86_64
xorg-x11-server-utils-7.4-7.fc11.x86_64
xorg-x11-drv-intel-2.6.99.902-1.fc11.x86_64
Comment 8 Ales Zelinka 2009-03-31 11:50:53 EDT
Created attachment 337327 [details]
Xorg.0.log
Comment 9 Mark Watts 2009-04-03 08:25:50 EDT
Created attachment 338030 [details]
Xorg.0.log after boot - dual-head
Comment 10 Mark Watts 2009-04-03 08:26:37 EDT
Created attachment 338031 [details]
Xorg.0.log after unmirroring the screens - dual-head
Comment 11 Mark Watts 2009-04-03 08:27:17 EDT
Created attachment 338032 [details]
Xorg.0.log after stacking the external screen above the internal one - dual-head
Comment 12 Matěj Cepl 2009-04-06 19:12:38 EDT

*** This bug has been marked as a duplicate of bug 489923 ***

Note You need to log in before you can comment on or make changes to this bug.