Bug 489973 - System to Rescue needs labels and UUIDs
System to Rescue needs labels and UUIDs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 14:23 EDT by John Reiser
Modified: 2009-03-20 16:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 16:16:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2009-03-12 14:23:46 EDT
Description of problem: In Rescue mode, the list of root partitions which appears in "System to Rescue" no longer has filesystem labels like it used to in Fedora 10.  So the labels should be restored.  Also, the UUID should be added.  So the list of root partitions should have lines like:
  01234567-89ab-cdef-0123-456789abcdef  /dev/sda1  /myLabel
which fits in 74 characters.


Version-Release number of selected component (if applicable):
anaconda-11.5.0.28

How reproducible: always


Steps to Reproduce:
1. boot Rescue mode, advance to finding root partitions
2.
3.
  
Actual results: List of root partitions which could be rescued has only device names such as "/dev/sda1", and lacks user label info such as "/myLabel", and lacks UUID.


Expected results: List of root partitions has UUID, device name, and label (if any) for each root partition.


Additional info:
Comment 1 Chris Lumens 2009-03-20 16:16:43 EDT
We can't do both the UUID and the label since the combination is likely to push us over the size limit.  I think labels can be fairly long.  Anyway, I've added the label back in, shrunk the disk path down to the name, and added the release string (which is probably one of the more helpful pieces of information in making this determination).  So this should make it much more useful and bring it closer in line with the graphical interface's upgrade UI.

Note You need to log in before you can comment on or make changes to this bug.