Bug 489980 - DPMS power saving fails to activate
DPMS power saving fails to activate
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 14:37 EDT by Mark Watts
Modified: 2009-04-24 23:53 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 23:53:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Watts 2009-03-12 14:37:04 EDT
Hardware:
http://www.smolts.org/client/show/pub_147a1a2f-5adb-4d82-8a2a-fdd35783929b

Following instructions at:
https://fedoraproject.org/wiki/QA:Testcase_intelvideo_dpms

Afer 20 mins the screensaver is still active.
Comment 1 Will Woods 2009-03-12 14:46:17 EDT
Same here, but if I ssh in and run:
  DISPLAY=:0.0
  xset dpms force off
the display powers down, as expected.

Maybe this is a problem in GNOME, and not the intel driver?
Comment 2 Jason Merrill 2009-03-12 15:08:35 EDT
Same here, http://www.smolts.org/client/show/pub_2fcec018-0916-4232-bb21-82f25e2d64f0

Waiting doesn't work, xset dpms does.
Comment 4 Jason Long 2009-03-12 16:06:12 EDT
same here,
http://www.smolts.org/client/show/pub_e5adecb3-9df6-4355-9dfc-a5622c85dc7f

In my case I booted with the "nomodeset" option (in contrast to the Test-case instructions), because of #488980.

So this problem, I think, is NOT dependent on kernel-mode-setting.
Comment 6 Jason Merrill 2009-03-27 16:11:38 EDT
Still present in rawhide as of 2009-03-27.
Comment 7 Matěj Cepl 2009-04-02 13:06:36 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 8 Rex Dieter 2009-04-02 13:12:36 EDT
for me (comment #3), I reproduced with no xorg.conf
Comment 9 Jason Long 2009-04-02 16:38:41 EDT
for me (comment #4), it now seems more like a Gnome bug. I only have this problem when I'm logged in.

I've found that at the GDM login screen, the monitor power-saving feature works just fine, with or without KMS enabled. I wait 10 minutes, and it goes to power-save mode, and then recovers from it, every time.

I am running without an xorg.conf. Since it does not seem to be a problem with the X server for me, I'm not going to bother capturing an Xorg.0.log file, sorry.
Comment 10 Adam Williamson 2009-04-02 16:46:03 EDT
I believe we found during the Radeon test day yesterday that it's actually known that GNOME's handling of DPMS is currently broken, and the test case was replaced with a different one:

https://fedoraproject.org/wiki/QA:Testcase_radeon_dpms

can you try that test on Intel and see if it works? If so, then the problem is the one in GNOME, which is I believe already reported.
Comment 11 Mark Watts 2009-04-03 08:02:38 EDT
Ok, since I ran the F11 intel test-day ISO, there wouldn't have been an xorg.conf file so I suspect the Gnome/DKMS issue is at fault here too.
Comment 12 Richard Hughes 2009-04-03 10:46:22 EDT
I've re-written the DPMS handling in gnome-power-manager in trunk last week, as it's horribly broken in rawhide at the moment. Could somebody try out the trunk code of gnome-power-manager please, and tell me if that fixes things. If it works okay, I'll backport to stable. Thanks.
Comment 13 Matěj Cepl 2009-04-06 08:34:58 EDT
(In reply to comment #12)
> I've re-written the DPMS handling in gnome-power-manager in trunk last week, as
> it's horribly broken in rawhide at the moment. Could somebody try out the trunk
> code of gnome-power-manager please, and tell me if that fixes things. If it
> works okay, I'll backport to stable. Thanks.  

And I think you should be rewarded with this bug. Reassigning.
Comment 14 Matthias Clasen 2009-04-24 23:53:24 EDT
This is in rawhide now:

* Tue Apr 21 2009 Richard Hughes  <rhughes@redhat.com> - 2.26.1-1
- Update to 2.26.1
- Fix the low capacity warning to fix rh#489832
- Backport DPMS and IDLETIME fixes from master to fix multiple bugs
- Connect to gnome-session and exit on logout
- Remove upstreamed patches

Note You need to log in before you can comment on or make changes to this bug.