Bug 490015 - TZ not calculated properly in JDK for location Americas/Raleigh(DST not recognized)
TZ not calculated properly in JDK for location Americas/Raleigh(DST not recog...
Status: CLOSED DUPLICATE of bug 489586
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 16:50 EDT by Jay Howell
Modified: 2009-05-15 14:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-15 14:43:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Howell 2009-03-12 16:50:09 EDT
Description of problem:

When using java.util.Date functions, the TZ is not automatically calculated for Raleigh locations.  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Configure Rawhide to use Raleigh as a location for time zone.
2.  Write a java app that does System.out.println( new java.util.Date());
3.  
4.  Went in and looked at the Timezone object and did 


  
Actual results:
It will return GMT-5 during Daylight Savings time 

Expected results:
it should return GMT-4

Additional info:
TimeZone.getTimeZone("America/Raleigh").getDSTSavings(), it returns 0.

The work around is to use a different major city in the same time zone.  When I change my Platform location to be New York it works ok.  I can also fix this by adding System.setProperty("user.timezone", "America/New_York"); in the beginning of my code.  

So it seems like a mismatch of TZ between the platform and the JVM.
Comment 1 Omair Majid 2009-03-19 11:25:35 EDT
Hi Jay,

I upgraded to rawhide from f10, and I cant find a way to use Raleigh as the local timezone. So i cant reproduce the issue :(. I cant find an entry for Raleigh in system-config-date, nor an file in /usr/share/zoneinfo.

Printing TimeZone.getTimeZone("America/Raleigh") in Java produces:
sun.util.calendar.ZoneInfo[id="GMT",offset=0,dstSavings=0,useDaylight=false,transitions=0,lastRule=null]

The timezone information is provided the tzdata package for the system and by tzdata-java package for java. They are built form the same set of sources, so there shouldnt be a mismatch.
Comment 2 Ioana Ivan 2009-03-25 00:37:14 EDT
I think America/New_York is the correct time zone for Raleigh. The problem is that java looks for time zone information in /etc/sysconfig/clock, where the ZONE parameter is specified as America/New York instead of America/New_York (see https://bugzilla.redhat.com/show_bug.cgi?id=489586)
Comment 3 Ioana Ivan 2009-05-15 14:43:40 EDT

*** This bug has been marked as a duplicate of bug 489586 ***

Note You need to log in before you can comment on or make changes to this bug.