Bug 490032 - Support configuration of character devices (serial, parallel, pv console)
Support configuration of character devices (serial, parallel, pv console)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 17:38 EDT by Darryl L. Pierce
Modified: 2015-06-21 20:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-13 11:05:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darryl L. Pierce 2009-03-12 17:38:48 EDT
Description of problem:

When creating a virtual machine, it would be nice to have an option that tells virt-install "create the vm, but don't turn it on at this time".
Comment 1 Daniel Berrange 2009-03-13 06:26:30 EDT
That is not really practical, because as part of provisioning the guest we often have to create temporary files for kernel/initrd/isos that we download. The initial XML config points to these temporary files for install, and once installed the config is updated. These temporary files are immediately deleted. So if we created, but didn't start the VM, then you wouldn't be able to start it later, because the temporary files are gone.

Can you explain the general use case / scenario you are trying to deal with, rather than a specific solution.
Comment 2 Darryl L. Pierce 2009-03-16 07:57:52 EDT
We're creating virtual machines that are used for testing purposes, using virt-install which is easier for creating the VM from a script.

One limitation we've found to this process is that virt-install does not allow us to define serial ports for the VM. So what we've done in the short term is:

1. use virt-install to define the vm
2. immediately kill the vm
3. edit the XML to inject a serial port
4. restart the vm

Perhaps an option to virt-install to create a serial port would be more practical?
Comment 3 Daniel Berrange 2009-03-16 08:24:25 EDT
Yes, if you need serial device configuration, we should definitely add that support natively instead of hacking around it.
Comment 4 Cole Robinson 2009-10-13 11:05:29 EDT
How important is this for RHEL5? This functionality is upstream, but it would be a pretty substancial backport, so I don't think it's the best idea for 5.5.

Since you currently have a working solution, I'm closing this WONTFIX. Please reopen if this is important for 5.5

Note You need to log in before you can comment on or make changes to this bug.