Bug 490053 - xen doesn't stop when entering runlevels 0, 1, or 6.
xen doesn't stop when entering runlevels 0, 1, or 6.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Michal Novotny
Virtualization Bugs
:
Depends On:
Blocks: 247523
  Show dependency treegraph
 
Reported: 2009-03-12 20:27 EDT by Bryan Mason
Modified: 2014-02-02 17:37 EST (History)
5 users (show)

See Also:
Fixed In Version: xen-3.0.3-85.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 06:08:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (392 bytes, patch)
2009-03-12 20:27 EDT, Bryan Mason
no flags Details | Diff

  None (edit)
Description Bryan Mason 2009-03-12 20:27:09 EDT
Created attachment 335035 [details]
Proposed patch

Description of problem:

    xend is not stopped when runlevels 0, 1, or 6 are entered.

Version-Release number of selected component (if applicable):

    xen-3.0.3-80.el5

How reproducible:

    Every time.

Steps to Reproduce:

    1. execute "poweroff" or "init 1"
  
Actual results:

    Watch the console.  Notice that the message "Stopping xend:" does
    not appear.  In runlevel 1, the xend process is still running:

    # init 1
    [...lots of stuff snipped...]
    # ps -ef | grep xend | grep -v grep
    root     3633      1  0 17:15 ?     00:00:00:00 python /usr/sbin/xend start
    root     3634   3633  0 17:15 ?     00:00:00:00 python /usr/sbin/xend start

Expected results:

    Xend should be stopped when switching to runlevels 0, 1, and 6.

Additional info:

    The problem is that the xend init script does not touch or remove
    /var/lock/subsys/xend.

    Requesting this as an exception for RHEL 5.4 becuase it's a simple
    fix and it blocks Bug 247523 (which is being investigated for RHEl
    5.4).

    Proposed patch attached.
Comment 2 Michal Novotny 2009-03-13 11:09:38 EDT
Ok, I tested this patch and it's working fine. No xend is here after applying this patch and switching to eg. runlevel 1. Changing to POST...
Comment 3 Jiri Denemark 2009-05-11 09:40:48 EDT
Fix built into xen-3.0.3-85.el5
Comment 5 Yewei Shao 2009-07-27 22:19:28 EDT
Verified on xen-3.0.3-91.
Comment 7 errata-xmlrpc 2009-09-02 06:08:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1328.html

Note You need to log in before you can comment on or make changes to this bug.