Bug 490067 - screen from withing XFCE Terminal sends NUL backspace
screen from withing XFCE Terminal sends NUL backspace
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-03-12 23:40 EDT by Ray Van Dolson
Modified: 2009-12-18 04:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-18 04:00:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ray Van Dolson 2009-03-12 23:40:27 EDT
Description of problem:
When using 'screen' from within an XFCE terminal, hitting backspace does nothing.  From a vi session it seems that a '^@' or NUL is being sent instead of ^H or ^?.  Workaround is to configure the XFCE Terminal to explicitly sent ^H or ^?, but Auto Detect should really do the "right thing" within screen.

Version-Release number of selected component (if applicable):

How reproducible:
So far, always.

Steps to Reproduce:
1. Start XFCE
2. Open an XFCE Terminal
3. Start screen (enter 'screen')
4. Type some text then try backspacing.
Actual results:
No backspace occurs.

Expected results:

Additional info:
I'm not sure if this is VTE's fault (bugs from other distro's led me to believe it was), XFCE Terminal's or screen's

My TERM is set to xterm in XFCE Terminal before starting up screen.  I have tried with vt100, tried starting screen with TERM=screen screen, and various .vimrc and .Xresources tricks to no avail.

I notice that if I ssh from the machine to somewhere else and start screen on the remote server, backspace works fine.  Odd?

I have been able to reproduce this on multiple Fedora 10 installs with virgin configs.  I tried older versions of screen (back to the one included in RHEL5).
Comment 1 Bug Zapper 2009-11-18 06:20:35 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 2 Bug Zapper 2009-12-18 04:00:53 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.