Bug 490079 - vt switching doesn't work with external monitor and intel driver
vt switching doesn't work with external monitor and intel driver
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 01:06 EDT by Per Bothner
Modified: 2009-04-23 10:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 10:44:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Per Bothner 2009-03-13 01:06:18 EDT
VT switching works fine with the laptop monitor.
However, when I switch to an external monitor, then it no longer works.
Doing C-A-F2 freezes the screen (no blanking).  Luckily C-A-F1 restores it.
This is a Lenovo T400.  IIRC correctly I have 4500HD but I'm not sure how to confirm the GPU - lspci shows 8086:2a43.
Comment 1 Matěj Cepl 2009-03-30 08:16:16 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Per Bothner 2009-03-30 21:22:35 EDT
I just tried it.  VT switching seem to be working now, at least when I boot up with the external monitor connected, which is what I mostly do.

However, that doesn't necessarily means the bug is gone, because there are still problems switching monitors:  I cannot switch to the laptop display using the Display Preferences application. If I try, both displays go dark.  I can bring the (external) display back (with the existing window and VT state) by VT switching - somehow that causes it to reset.

So there is an interesting connection between VT switching and monitor switching, but maybe it's best to concentrate on the issues with monitor switching.

My entry (under "bothner") in https://fedoraproject.org/wiki/QA/Test_Days/2009-03-12 does mention some issues with external monitors, and links a few bug reports that might be related.  But I'm not sure if they're quiet what I'm seeing.
Comment 3 Matěj Cepl 2009-04-23 10:25:42 EDT
Could we get those blogs, please?
Comment 4 Per Bothner 2009-04-23 10:44:51 EDT
As I wrote in comment #2, vt switching seems to work now.

I also just tried switching from external monitor to laptop and back.
That works again (yeah!), so I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.