Bug 490085 - esound upgrade path to F11 broken
esound upgrade path to F11 broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: esound (Show other bugs)
rawhide
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-03-13 01:56 EDT by Christopher Beland
Modified: 2009-03-15 23:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-15 23:31:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2009-03-13 01:56:43 EDT
There is an EVR problem causing the F10 -> F11 upgrade path for esound to break.  For example, I have installed 

esound-libs-0.2.41-1.fc10.x86_64
esound-debuginfo-0.2.41-1.fc10.x86_64

These did not get changed by "yum update" until I removed them manually with "rpm -e --nodeps". "yum install esound-debuginfo esound-libs" then pulls:

esound-libs-0.2.40-2.fc11.x86_64.rpm
esound-debuginfo-0.2.40-2.fc11.x86_64.rpm
Comment 1 Adam Williamson 2009-03-13 14:24:09 EDT
esound itself is in fact now obsoleted by PulseAudio. esound-libs is sticking around for apps which use libesd directly:

[adamw@adam Download]$ repoquery --whatrequires `repoquery --provides esound-libs` | sort -u
adplay-0:1.6-5.fc11.x86_64
allegro-esound-plugin-0:4.2.2-12.fc11.x86_64
audacious-plugins-esd-0:1.5.1-3.fc11.x86_64
avidemux-cli-0:2.4.3-8.fc11.x86_64
avidemux-gtk-0:2.4.3-8.fc11.x86_64
avidemux-qt-0:2.4.3-8.fc11.x86_64
BasiliskII-0:1.0-0.20060501.3.fc10.x86_64
dopewars-0:1.5.12-6.fc11.x86_64
e16-0:0.16.8.15-2.fc11.x86_64
esound-devel-1:0.2.40-2.fc11.i586
esound-devel-1:0.2.40-2.fc11.x86_64
esound-libs-1:0.2.40-2.fc11.i586
esound-libs-1:0.2.40-2.fc11.x86_64
esound-tools-1:0.2.40-2.fc11.x86_64
festival-0:1.96-10.fc11.x86_64
festival-speechtools-libs-0:1.2.96-10.fc11.i586
festival-speechtools-libs-0:1.2.96-10.fc11.x86_64
festival-speechtools-utils-0:1.2.96-10.fc11.x86_64
gg2-esound-0:2.3.0-11.fc11.x86_64
gnome-libs-1:1.4.2-13.fc11.i586
gnome-libs-1:1.4.2-13.fc11.x86_64
gnubg-1:0.9.0.1-7.fc11.x86_64
gok-0:2.25.91-2.fc11.x86_64
libglade-1:0.17-22.fc11.i586
libglade-1:0.17-22.fc11.x86_64
libhildon-0:2.0.6-3.fc11.i586
libhildon-0:2.0.6-3.fc11.x86_64
lxdream-0:0.9-1.fc10.x86_64
madplay-0:0.15.2b-5.fc10.x86_64
moon-buggy-0:1.0.51-3.fc11.x86_64
openal-0:0.0.9-0.17.20060204cvs.fc11.i586
openal-0:0.0.9-0.17.20060204cvs.fc11.x86_64
reciteword-0:0.8.4-3.fc9.x86_64
SheepShaver-0:2.3-0.6.20060514.fc10.x86_64
spacechart-0:0.9.5-2.fc11.x86_64
timidity++-0:2.13.2-17.fc11.x86_64
wine-esd-0:1.1.15-2.fc11.i586
xarchon-0:0.50-8.fc11.x86_64
xine-lib-extras-0:1.1.16.2-5.fc11.i586
xine-lib-extras-0:1.1.16.2-5.fc11.x86_64
xlockmore-0:5.26.1-2.fc11.x86_64
xmms-esd-1:1.2.11-4.20071117cvs.fc11.x86_64

for interest.

It seems that Matthias Clasen sent this update:

* Mon Nov 24 2008 Matthias Clasen <mclasen@redhat.com> 0 1:0.2.41-1
- Update t 0.2.41

to F10, but not Rawhide. So the update should be sent to Rawhide.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.