Bug 490093 - VPNC disconnection
VPNC disconnection
Product: Fedora
Classification: Fedora
Component: vpnc (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-03-13 04:14 EDT by Jean-pierre Cartal
Modified: 2010-11-25 15:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-03-13 04:32:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jean-pierre Cartal 2009-03-13 04:14:23 EDT
Description of problem:

VPNC disconnects after 1 hour, probably due to rekeying not being properly handled as the ipsec lifetime attributes, as sent by the concentrator is 3600 seconds.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start the vpn connection using vpnc
2. Wait for the ipsec lifetime
3. Disconnection
Actual results:

VPN is disconnected

Expected results:

No disconnection

Additional info:
Official Cisco client works fine.
Level 3 debug file available on request.
Comment 1 Tomas Mraz 2009-03-13 04:32:50 EDT
Please report the problem upstream at the https://lists.unix-ag.uni-kl.de/mailman/listinfo/vpnc-devel mailing list.
Comment 2 Pavel Urban 2010-11-25 15:34:06 EST
Can you please reopen this bug? Phase2-rekeying still doesn't work in Fedora 14 while there is support for it in upstream SVN (see http://www.unix-ag.uni-kl.de/~massar/vpnc/). I've tried to recompile SVN version into rpm (just replaced tar.gz in source package with the one I got from SVN) and after commenting out line 3099 in vpnc.c it works just fine. I hope for better review, though - I'm not a programmer.

Note You need to log in before you can comment on or make changes to this bug.