Bug 490110 - installer crashes with DeviceException on PS3
installer crashes with DeviceException on PS3
Status: CLOSED DUPLICATE of bug 488800
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 06:58 EDT by Kazunori Asayama
Modified: 2009-03-13 09:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 09:54:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anacdump.txt by anaconda-11.5.0.28-1 (44.15 KB, text/plain)
2009-03-13 07:00 EDT, Kazunori Asayama
no flags Details

  None (edit)
Description Kazunori Asayama 2009-03-13 06:58:44 EDT
Description of problem:

On PLAYSTATION 3 (60GB model), installer crashes with DeviceException.

Version-Release number of selected component (if applicable):

anaconda-11.5.0.28-1

How reproducible:

Every time.

Steps to Reproduce:
1. Start installer.
2. Go to 'Warning! This is pre-relase software!' page and select 'Install anyway'.
  
Actual results:

anaconda crashes with the following message:

Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/device.py", line 48, in __init__
    self.__device = _ped.device_get(path)
  File "/usr/lib/anaconda/storage/devices.py", line 671, in __init__
    self.partedDevice = parted.Device(path=self.path)
  File "/usr/lib/anaconda/storage/devicetree.py", line 980, in addUdevDevice
    initcb=cb)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1272, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 221, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 64, in storageInitialize
    anaconda.id.storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 697, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1012, in <module>
    anaconda.intf.run(anaconda)
DeviceException: Could not find device for path /dev/sda

Expected results:

Installer goes on.

Additional info:

/dev/sda should be one of flash memory card readers on PS3 60GB model. When I tried rawhide, no flash memory card was in the readers.

Other platforms than PS3, including x86 PCs, may have the same problem if any empty card readers are connected. However, I haven't tried that.
Comment 1 Kazunori Asayama 2009-03-13 07:00:09 EDT
Created attachment 335070 [details]
anacdump.txt by anaconda-11.5.0.28-1
Comment 2 Chris Lumens 2009-03-13 09:54:07 EDT

*** This bug has been marked as a duplicate of bug 488800 ***

Note You need to log in before you can comment on or make changes to this bug.