Bug 490112 - gnome-python2-evince should depend on evince not evince-devel
Summary: gnome-python2-evince should depend on evince not evince-devel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-python2-desktop
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F11Blocker, F11FinalBlocker FedoraOLPCDelta
TreeView+ depends on / blocked
 
Reported: 2009-03-13 11:15 UTC by Peter Robinson
Modified: 2009-03-13 14:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-13 12:59:11 UTC


Attachments (Terms of Use)

Description Peter Robinson 2009-03-13 11:15:25 UTC
The evince subpackage should depend on plain evince, not the evince-devel package. It pulls in massive amounts of unnecessary devel packages.

%package -n gnome-python2-evince
Summary: Python bindings for interacting with evince
License: LGPLv2
Group: Development/Languages
Requires: %{name} = %{version}-%{release}
Requires: evince-devel >= %{evince_version}

Comment 1 Matthew Barnes 2009-03-13 12:59:11 UTC
Thanks.  Fixed in gnome-python2-desktop-2.25.91-3.fc11.

Comment 2 Peter Robinson 2009-03-13 13:08:18 UTC
Excellent! Any chance of this making the F11 Beta?

Comment 3 Matthew Barnes 2009-03-13 13:37:32 UTC
Can't say for sure.  Depends on which Rawhide refresh the Beta is rolled from.
But it's still a week and a half out, so it seems likely it will.

Comment 4 Peter Robinson 2009-03-13 13:52:22 UTC
I thought from the 10th (beta freeze fate) you had to explicitly request builds get tagged for the beta.

Comment 5 Matthew Barnes 2009-03-13 14:24:05 UTC
Ah, you might be right.  I'll ask and request if necessary.


Note You need to log in before you can comment on or make changes to this bug.