Bug 490127 - No Site local adress for network interface
No Site local adress for network interface
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.8
All Linux
low Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 09:42 EDT by Jan Ščotka
Modified: 2009-03-17 14:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 14:11:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Ščotka 2009-03-13 09:42:40 EDT
Description of problem:
Im not sure if this problem is caused initscripts package, maybe by ifconfig or other, I don't know.

I'm not sure if it is a problem, but in RHEL5 and Fedora there is Site local adress default created when, system is startuped
something like 
inet6 addr: fec0::f101:216:3eff:fe0f:7f83/64 Scope:Site

Steps to Reproduce:
$ ifconfig (and see if line exists (where is Scope:Site))
  
Actual results:
No Site Scope adress, therefore computer isnt accessible via ipv6 over net default

Expected results:
at least one Site local adress
inet6 addr: fec0::f101:216:3eff:fe0f:7f83/64 Scope:Site

Additional info:
Sorry Folks if this isnt propper package.
Comment 1 Bill Nottingham 2009-03-13 15:12:58 EDT
Is the ipv6 module loaded at all?
Comment 2 Jan Ščotka 2009-03-16 04:40:25 EDT
I think yes,
because Link local adress is assigned.
for example one of the stable system, (stable systems should have everything turn on) - and the problem is at all machines with RHEL4

# lsmod (of i386 ss)
Module                  Size  Used by
oprofile               38433  1 
nls_utf8                6209  0 
cifs                  214205  0 
nfs                   222761  3 
lockd                  66249  2 nfs
nfs_acl                 7745  1 nfs
parport_pc             28033  0 
lp                     15661  0 
parport                38153  2 parport_pc,lp
autofs4                26053  0 
i2c_dev                14529  0 
i2c_core               26305  1 i2c_dev
sunrpc                144165  7 nfs,lockd,nfs_acl
cpufreq_powersave       5953  0 
ib_srp                 36189  0 
ib_sdp                 53885  0 
ib_ipoib               81901  0 
md5                     8129  1 
ipv6                  243937  83 ib_ipoib
rdma_ucm               20037  0 
rdma_cm                38141  2 ib_sdp,rdma_ucm
iw_cm                  13381  1 rdma_cm
ib_addr                12485  1 rdma_cm
ib_umad                22121  0 
ib_ucm                 22213  0 
ib_uverbs              41705  2 rdma_ucm,ib_ucm
ib_cm                  41785  4 ib_srp,ib_ipoib,rdma_cm,ib_ucm
ib_sa                  42829  4 ib_srp,ib_ipoib,rdma_cm,ib_cm
ib_mad                 40025  3 ib_umad,ib_cm,ib_sa
ib_core                58561  12 ib_srp,ib_sdp,ib_ipoib,rdma_ucm,rdma_cm,iw_cm,ib_umad,ib_ucm,ib_uverbs,ib_cm,ib_sa,ib_mad
loop                   20681  0 
dm_multipath           23625  0 
button                 10705  0 
battery                12997  0 
ac                      8901  0 
joydev                 14465  0 
ehci_hcd               33221  0 
uhci_hcd               33241  0 
i5000_edac             13121  0 
edac_mc                29705  1 i5000_edac
bnx2                  141661  0 
dm_snapshot            21477  0 
dm_zero                 6465  0 
dm_mirror              32581  0 
ext3                  120393  2 
jbd                    60249  1 ext3
dm_mod                 67433  9 dm_multipath,dm_snapshot,dm_zero,dm_mirror
ata_piix               19781  0 
libata                106013  1 ata_piix
cciss                  69805  3 
sd_mod                 20801  0 
scsi_mod              121293  4 ib_srp,libata,cciss,sd_mod

# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:1E:0B:8F:EE:36  
          inet addr:10.16.40.46  Bcast:10.16.47.255  Mask:255.255.248.0
          inet6 addr: fe80::21e:bff:fe8f:ee36/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6555330 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2287507 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:186205859 (177.5 MiB)  TX bytes:337466221 (321.8 MiB)
          Interrupt:185 Memory:f8000000-f8012100 

so Link local adress is assigned, but not Site local
Comment 3 Bill Nottingham 2009-03-16 12:05:10 EDT
Can you attach your network configuration for both releases?
Comment 5 Bill Nottingham 2009-03-17 11:48:25 EDT
Do you have any IPv6 options set in your RHEL 5 configuration?
Comment 6 Bill Nottingham 2009-03-17 12:04:34 EDT
(This includes both /etc/sysconfig/network and /etc/sysconfig/network-scripts)
Comment 8 Bill Nottingham 2009-03-17 14:11:56 EDT
We only create link-local by default - you'd have to do extra configuration to get site addresses. So RHEL 4 is behaving correctly.

Note You need to log in before you can comment on or make changes to this bug.