Bug 490145 - Sound plays while application volume is 0
Sound plays while application volume is 0
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 11:08 EDT by Michael Monreal
Modified: 2009-04-22 19:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 19:46:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
infinite bD (53.38 KB, image/png)
2009-03-18 13:40 EDT, Michal Nowak
no flags Details

  None (edit)
Description Michael Monreal 2009-03-13 11:08:12 EDT
Again, no idea if this is a g-m or pulse bug :/

First, make sure all output volumes are set to 100% (the global and the application sound level). Play a song in totem (also tested with banshee: same problem). Now open gnome-volume-control and reduce the global volume all the way down to 0%. The per-application volume will decrease as well. Both gnome-volume-control and totem will show sound as muted. Now, increase the global volume to 100% again. You will again hear sound, but totem's application sound volume is still set to 0% and totem also still shows the muted speaker.
Comment 1 Michal Nowak 2009-03-18 13:40:17 EDT
Created attachment 335743 [details]
infinite bD

Nearly any random playing with in-application sound volume and with the system one in dock, exposes the problem.

* app looks muted
* system volume in docs shows some random amount of dB
* I hear the sound

I noticed that after the file in Totem changed, the volume was finally muted.
Comment 2 Bastien Nocera 2009-03-25 09:08:51 EDT
bug 488532 won't be helping that. As well as the fact that Totem won't update its display if the volume is changed externally.
Comment 3 Bastien Nocera 2009-04-22 10:50:20 EDT
Do you still see that problem since the fixes hit gnome-media and Totem?
Comment 4 Michael Monreal 2009-04-22 18:13:31 EDT
No, looking good now. Thanks!

Note You need to log in before you can comment on or make changes to this bug.