Bug 490180 - Cannot create PXE-bootable Fedora 10 Live CD
Cannot create PXE-bootable Fedora 10 Live CD
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 13:34 EDT by Need Real Name
Modified: 2010-10-07 21:04 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-19 20:44:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2009-03-13 13:34:45 EDT
I've been chatting with Michael DeHaan trying to get a machine PXE booting a Fedora 10 LiveCD. 

I've followed the instructions found here:

https://fedorahosted.org/cobbler/wiki/HowToPxeAnyLiveCd

But it creates a menu entry where root=/root/F10-i686-Live.iso

Michael chatted with Chris and suggested that it should actually be

  root=CDLABEL=<name of CD>

I tried that, but it doesn't work..and now for details:

[root@cobbler cobbler]# file F10-i686-Live.iso
F10-i686-Live.iso: ISO 9660 CD-ROM filesystem data 'F10-i686-Live                  ' (bootable)

from the pxelinux.cfg/default:

LABEL F10-live-Chris
	KERNEL /images/F10-live/vmlinuz0
	APPEND initrd=/images/F10-live/initrd0.img root=CDLABEL=F10-i686-Live rootfstype=iso9660 ro liveimg rootflags=loop


Doing PXE boot of that menu item:

Loading /images/F10-live/vmlinuz0...one row...
Loading /images/F10-live/initrd0.img.....six minutes of dots...
...
md: ... autorun DONE.
VFS: Cannot open root device "CDLABEL=F10-i686-Live" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
0b00   1048575 sr0 driver: sr
0800 117220824 sda driver: sd
  0801     200781  sda1
  0802  117017460 sda2
Kernel panic - not syncing: CFS: Unable to mount root fs on unknown-block(0,0)
Comment 1 Sam Sheng 2009-03-16 17:18:53 EDT
I have the same error message on i386 platform.
Comment 3 Alan Pevec 2009-03-31 07:02:16 EDT
CDLABEL won't work for loop mounted ISO file.

But I don't see how and where do you get root=/root/F10-i686-Live.iso

It is not in pxelinux.cfg/default generated by livecd-iso-to-pxeboot, even though this is not used by cobbler.

And cobbler instructions include correct root= parameter:
 cobbler distro edit --name=liveF9 --kopts='root=/f9live.iso rootfstype=iso9660 rootflags=loop !text !lang !ksdevice'
Comment 4 Need Real Name 2009-04-02 19:53:41 EDT
Hi Alan,

From what I've been told, it should actually generate a line such that root=CDLABEL=<value of cd label>, instead it generates a line with the path of the .iso on the host system.

Neither of these options in pxelinux.cfg/default work for me.
Comment 5 Alan Pevec 2009-05-13 09:44:53 EDT
> instead it generates a line with the path of the .iso on the host system

it's not on the host system, it's the ISO file in the initramfs, so it must be exactly /name-you-supplied-to-livecd-iso-to-pxeboot.iso

https://fedorahosted.org/cobbler/wiki/HowToPxeAnyLiveCd has correct instructions:
> Be sure the "/name-goes-here.iso" part of the path matches up with the ISO you ran livecd-iso-to-pxeboot against exactly or the booting will not be successful.


> Michael chatted with Chris and suggested that it should actually be
>  root=CDLABEL=<name of CD>

Michael is DeHann (cced) but not sure who is Chris?

CDLABEL= can't work b/c you need to specify which file is to be loop mounted
Comment 6 Steve Kilduff 2009-10-08 05:50:22 EDT
I am having the same problems with Fedora10 and 11 livecds, I cannot get the root iso to mount. I have tried all of the options above for root= but none work.

Has anyone sucessfully completed this task with cobbler? And if so, what boot options did you use to do so?

Thanks,
Steve
Comment 7 Michael Cronenworth 2010-06-11 18:19:35 EDT
I've run into this today.

# livecd-iso-to-pxeboot Fedora-13-i686-Live.iso
# cobbler distro add --name=liveF13 --kernel=/home/me/tftpboot/vmlinuz0 --initrd=/home/me/tftpboot/initrd0.img
# cobbler distro edit --name=liveF13 --kopts='root=/Fedora-13-i686-Live.iso rootfstype=iso9660 rootflags=loop !text !lang !ksdevice'
# cobbler profile add --name=liveF13 --distro=liveF13

Booting the image results in the same error as the original description. "Cannot open root device "/Fedora-13-i686-Live.iso" or unknown-block(0,0)"

Fedora 12 x86_64 cobbler server
cobbler-2.0.3.1-3.fc12.noarch

Am I doing something wrong or should this bug be reopened?
Comment 8 Tomas Pecina 2010-06-19 03:25:16 EDT
The same problem in F13, this definitely looks like a bug and it SHOULD be reopened.
Comment 9 Alan Pevec 2010-06-19 20:44:46 EDT
Retested directly with generated pxelinux.cfg/default and it worked for me.
Note that now with Dracut root parameter syntax is different:
 root=live:/Fedora-13-x86_64-Live.iso

If using Cobbler, make sure you use parameters from the generated pxelinux.cfg.
Comment 10 Tomas Pecina 2010-06-20 02:26:05 EDT
I noticed the difference, and tried it many times both with and without "live:". No success yet.

I admit the only problem may be with inadequate documentation, but even if this is the case, it should be addressed. Linux should be perceived as a poorly documented operating system.
Comment 11 Tomas Pecina 2010-06-20 02:26:41 EDT
Oops!

should -> should not
Comment 12 Alan Pevec 2010-06-20 17:09:58 EDT
(In reply to comment #10)
> I noticed the difference, and tried it many times both with and without
> "live:". No success yet.

Please provide more details.

Regarding docs, Cobbler configuration is currently out of scope for livecd-iso-to-pxeboot, and for direct PXE it prints the correct instructions:
> Copy tftpboot/ subdirectory to /tftpboot or a subdirectory of /tftpboot."
> Set up your DHCP, TFTP and PXE server to serve /tftpboot/.../pxeboot.0"
Comment 13 Tomas Pecina 2010-06-21 18:32:04 EDT
This is the sequence of commands I entered:

cd /srv/
mkdir livecd
cd livecd
cp /var/www/html/samba.pecina.cz/Archive/Fedora/Fedora-13-x86_64-Live.iso .
livecd-iso-to-pxeboot Fedora-13-x86_64-Live.iso 
cp tftpboot/vmlinuz0 .
cp tftpboot/initrd0.img .
cobbler distro add --name=Fedora13-Live --kernel=/srv/livecd/vmlinuz0 --initrd=/srv/livecd/initrd0.img 
cobbler distro edit --name=Fedora13-Live --kopts='root=/Fedora-13-x86_64-Live.iso rootfstype=iso9660 rootflags=loop !text !lang !ksdevice'
cobbler profile add --name=Fedora13-Live --distro=Fedora13-Live
cobbler sync

I tried it with and w/o live - in both cases, the result was the error message mentioned above.

Something is obviously wrong. What?
Comment 14 Michael Cronenworth 2010-06-22 10:03:46 EDT
(In reply to comment #9)
> Retested directly with generated pxelinux.cfg/default and it worked for me.
> Note that now with Dracut root parameter syntax is different:
>  root=live:/Fedora-13-x86_64-Live.iso

VFS: Cannot open root device "live:/Fedora-13-i686-Live.iso" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
0b00               1048575 sr0 driver: sr
0800              33554432 sda driver: sd
  0801               204800 sda1
  0802             33346921 sda2

Not working here.

> 
> If using Cobbler, make sure you use parameters from the generated pxelinux.cfg.    

I did.

rootflags=loop rd_NO_LUKS ro liveimg rd_NO_MD quiet rhgb rootfstype=auto root=live:/Fedora-13-i686-Live.iso
Comment 15 Alvaro Fonseca 2010-10-07 21:04:40 EDT
I was wondering if a resolution has been found for this problem? I am having the an error similar to the ones described above "No root device found". I am using the syntax: 
append initrd=initrd0 root=live:/Fedora.ISO rootfstype=iso9660 rootflags=loop

Note You need to log in before you can comment on or make changes to this bug.