Bug 490196 - Abiword crashes if "play sound effects when buttons are clicked" is enabled in Fedora 10 Gnome desktop
Abiword crashes if "play sound effects when buttons are clicked" is enabled i...
Status: CLOSED DUPLICATE of bug 482797
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 14:47 EDT by Juha Grönman
Modified: 2009-03-19 07:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 07:13:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juha Grönman 2009-03-13 14:47:46 EDT
Description of problem:
If you select System -> Preferences -> Hardware -> Sound and select Sounds page
and play sound effects when buttons are clicked, then Abiword crashes when you
open a file and after that do something that causes a sound to be played. E.g.
browse the menu bar buttons.

If you have started the Abiword in console, the following text is displayed
when Abiword crashes:

E: thread-posix.c: Assertion 'pthread_setspecific(t->key, userdata) == 0'
failed at pulsecore/thread-posix.c:200, function pa_tls_set(). Aborting.


Version-Release number of selected component (if applicable):
uname -a
Linux localhost.localdomain 2.6.27.19-170.2.35.fc10.x86_64 #1 SMP Mon Feb 23 13:00:23 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

rpm -qa |grep pulsea
pulseaudio-module-zeroconf-0.9.14-1.fc10.x86_64
pulseaudio-utils-0.9.14-1.fc10.x86_64
pulseaudio-core-libs-0.9.14-1.fc10.x86_64
pulseaudio-module-x11-0.9.14-1.fc10.x86_64
pulseaudio-module-gconf-0.9.14-1.fc10.x86_64
pulseaudio-libs-0.9.14-1.fc10.x86_64
pulseaudio-0.9.14-1.fc10.x86_64
xine-lib-pulseaudio-1.1.16.2-1.fc10.x86_64
pulseaudio-libs-zeroconf-0.9.14-1.fc10.x86_64
pulseaudio-esound-compat-0.9.14-1.fc10.x86_64
alsa-plugins-pulseaudio-1.0.18-2.fc10.x86_64
pulseaudio-libs-glib2-0.9.14-1.fc10.x86_64

rpm -qa | grep abi
abiword-2.6.6-1.fc10.x86_64
lohit-fonts-punjabi-2.3.1-1.fc10.noarch
libabiword-2.6.6-1.fc10.x86_64
m17n-db-punjabi-1.5.3-1.fc10.noarch
m17n-contrib-punjabi-1.1.8-2.fc10.noarch


How reproducible:
Always

Steps to Reproduce:
1. Enbale play sound effects when buttons are clicked
2. Start Abiword. Open a file.
3. Browse menu bar buttons.
  
Actual results:
Abiword crashes.

Expected results:
Should not.

Additional info:
Comment 1 Lennart Poettering 2009-03-19 07:13:52 EDT
Appears to be duplicate of #482797

*** This bug has been marked as a duplicate of bug 482797 ***

Note You need to log in before you can comment on or make changes to this bug.