Bug 4902 - PNP cdrom - can'd cold boot - hangs the system
Summary: PNP cdrom - can'd cold boot - hangs the system
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-04 03:49 UTC by margarita
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-04 22:13:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description margarita 1999-09-04 03:49:44 UTC
The cdrom prevents booting unless WIndows has been booted
and Red Hat boot is invoked without a power off.

When the system hangs on a cold boot the message on the
console refers to pc_cdrom is confused - lost interupt
reason 0x1. Values entered on Lilo have no effect on this
error.

Boot's OK on windows.

Comment 1 David Lawrence 1999-09-07 17:16:59 UTC
We will need to know more about your hardware. For example brand/model
of the cd-rom that you are having trouble with. Is it an ATAPI IDE
drive or a proprietary drive?

Comment 2 margarita 1999-09-18 16:55:59 UTC
I am using:
io magic 52x cdrom on ide 2nd slot as primary(not slave) /dev/hdc
   It is ATAPI as far as I know
   The 1st ide contains 2 drives 2.2GIG each - Western Digital

IWILL premium motherboard
64 MEG 60 ns EDO memory
One IBM 9.1 GIG SCSI drive.

More notes:

This condition existed before I installed the SCSI Drive.

IF I BOOT WINDOWS, AND THEN REBOOT RED HAT WITHOUT POWER OFF THE
CD ROM WILL WORK. IT WILL NOT WORK FROM A COLD - POWER OFF BOOT.

Hope this helps. I want eventually to get rid of the windows OS
entirely.

Comment 3 Patrick Monnerat 2000-02-08 17:48:59 UTC
I have the same problem with RHL 6.1 and ATAPI/IDE CD-ROM as single (master)
unit on 2nd IDE controller. However, if I disable the recognition of the CD-ROM
drive at the AMI-BIOS setup level (but not the controller of course!), the
systems boot properly... Since I never succeeded booting an el-Torito CD-ROM
with this computer, I can imagine that this BIOS version does some dirty CD-ROM
initializations that DOS and WinNT reset, but not Linux... shame !

Comment 4 Ben LaHaise 2000-10-04 22:13:33 UTC
Is this still happening with the 2.2.16-22 kernel?

Comment 5 Brent Fox 2002-06-05 03:57:45 UTC
Closing due to lack of information.


Note You need to log in before you can comment on or make changes to this bug.