Bug 490202 - Please package the video thumbnailer separately
Please package the video thumbnailer separately
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 15:30 EDT by Julian Sikorski
Modified: 2009-04-29 07:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 06:44:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Thumbnailer split, first attempt (2.11 KB, patch)
2009-03-13 15:30 EDT, Julian Sikorski
no flags Details | Diff
Thumbnailer split, second attempt (2.55 KB, patch)
2009-03-20 07:15 EDT, Julian Sikorski
no flags Details | Diff

  None (edit)
Description Julian Sikorski 2009-03-13 15:30:50 EDT
Created attachment 335146 [details]
Thumbnailer split, first attempt

Description of problem:
Due to the way the thumbnailer gconf entries are designed, it is currently impossible to have two pieces of software thumbnail the same mimetype. As a result, when nailer [1], which I've packaged for RPM Fusion is installed alongside totem, the first application that gets uninstalled will take the gconf entries with itself, leaving no thumbnailer configured.
Having the thumbnailer part of totem packaged separately would allow alternatives, or Conflicts to be less severe - one might want to have mplayer do the thumbnailing, but keep totem installed for DVDs, for example.
The attached patch against devel spec is my initial attempt to split totem.
Comment 1 Bastien Nocera 2009-03-19 19:27:14 EDT
Post script to install the schemas are broken.

And I forgot to realise that the gallery screenshot function of totem requires the totem-video-thumbnailer binary.

So the binary would need to be in the main package, and just the schemas in the sub package.
Comment 2 Julian Sikorski 2009-03-20 07:15:09 EDT
Created attachment 336026 [details]
Thumbnailer split, second attempt

How about now?
Comment 3 Bastien Nocera 2009-04-29 06:44:06 EDT
I'm really not sure it's actually worth my time crippling the package for the sake of a third-party thumbnailer.

1) It creates a sub-package with only data in it, which serves no real purpose
2) It doesn't install by itself on upgrades (so people lose thumbnailing for no reason)

The thumbnail selection process in libgnomeui should be fixed instead, to allow multiple packages to register as thumbnailers for the same mime-types.
Comment 4 Julian Sikorski 2009-04-29 06:56:02 EDT
libgnomeui is planned to be killed, so I doubt anyone would be willing to work on that. Which gnome component the bug should be filed against then?
Comment 5 Bastien Nocera 2009-04-29 07:25:04 EDT
See in the gnome-thumbnail section in http://live.gnome.org/LibgnomeMustDie

Your best bet is to file it against gnome-desktop upstream.

My guess is that your problem matches http://bugzilla.gnome.org/show_bug.cgi?id=497264

Note You need to log in before you can comment on or make changes to this bug.