Bug 490206 - Internal error if CD is not available
Internal error if CD is not available
Status: CLOSED DUPLICATE of bug 473154
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 16:04 EDT by Michael Monreal
Modified: 2009-04-04 18:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-04 18:10:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (73.74 KB, image/png)
2009-03-13 16:06 EDT, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-03-13 16:04:56 EDT
Create a VM which should install from CD. Remove the CD, then try to boot. You will be presented with a very ugly error window (see screenshot). VMM should catch this error and just ask for a CD.
Comment 1 Michael Monreal 2009-03-13 16:06:29 EDT
Created attachment 335151 [details]
Screenshot
Comment 2 Mark McLoughlin 2009-03-25 13:22:42 EDT
(In reply to comment #0)
> Create a VM which should install from CD. Remove the CD, then try to boot. You
> will be presented with a very ugly error window (see screenshot).

Could you give a little more details on the exact steps to reproduce?

> VMM should catch this error and just ask for a CD.

I'm not sure that's possible - it's no different from e.g. someone deleting a guest disk image from the command line just before starting a guest.

"internal error" is a bit bogus, I admit
Comment 3 Michael Monreal 2009-03-28 09:08:03 EDT
(In reply to comment #2)
> Could you give a little more details on the exact steps to reproduce?
I don't think I can describe better than in comment #0 :)

> it's no different from e.g. someone deleting a guest disk image 
> from the command line just before starting a guest
It's much more likely that someone starts a VM which relies on a *mounted* CD than someone deleting a disk image by hand I think.

Anyway, I'm not talking about ejecting a CD after pressing "start vm". You could for example configure a CD, reboot the physical box, run virt manager again and now try to start the vm.
Comment 4 Cole Robinson 2009-04-04 18:10:23 EDT

*** This bug has been marked as a duplicate of bug 473154 ***

Note You need to log in before you can comment on or make changes to this bug.