Bug 490237 - Mouse stops responding
Mouse stops responding
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 19:06 EDT by Dark Falcon
Modified: 2009-03-14 15:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-14 15:13:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dark Falcon 2009-03-13 19:06:31 EDT
I use evdev for both mouse and keyboard because I have a two-head setup on this machine. I recently upgraded to

xorg-x11-drv-evdev-2.1.3-1.fc10.i386

After this upgrade, my usb optical mouse periodically stops working. The light will brighten when moved, but the cursor does not move. If I kill X and restart, it works fine again. This happens 1-3 times a day.

I have downgraded to

xorg-x11-drv-evdev-2.1.2-1.fc10.i386

and the problem has disappeared. The second mouse works fine to my knowledge.

---------------

Mouse configuration (Mouse0):

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "evdev"
        Option      "Device" "/dev/input/by-id/usb-HP_Multimedia_Keyboard_Hub-event-kbd"
        Option      "XkbModel" "evdev"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/by-id/usb-HP_HP_USB_WHEEL_MOUSE-mouse"
EndSection

Section "InputDevice"
        Identifier  "Keyboard1"
        Driver      "evdev"
        Option      "Device" "/dev/input/by-id/usb-_USB_Keyboard-event-kbd"
        Option      "XkbModel" "evdev"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse1"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/by-id/usb-Logitech_Optical_USB_Mouse-mouse"
EndSection

---------------

End of XOrg logs:

While X is running normally:
(II) config/hal: Adding input device Sleep Button (CM)
(EE) config/hal: NewInputDeviceRequest failed
(II) config/hal: Adding input device Power Button (FF)
(EE) config/hal: NewInputDeviceRequest failed
 
Killed X with mouse working:
(II) config/hal: Adding input device Sleep Button (CM)
(EE) config/hal: NewInputDeviceRequest failed
(II) config/hal: Adding input device Power Button (FF)
(EE) config/hal: NewInputDeviceRequest failed
(II) UnloadModule: "mouse"
(II) Keyboard0: Close
(II) UnloadModule: "evdev"
 
Killed X after mouse stopped working:
(II) config/hal: Adding input device Sleep Button (CM)
(EE) config/hal: NewInputDeviceRequest failed
(II) config/hal: Adding input device Power Button (FF)
(EE) config/hal: NewInputDeviceRequest failed
(II) 3rd Button detected: disabling emulate3Button
(II) config/hal: Adding input device HP HP USB WHEEL MOUSE
(EE) config/hal: NewInputDeviceRequest failed
(II) UnloadModule: "mouse"
(II) Keyboard0: Close
(II) UnloadModule: "evdev"
Comment 1 Dark Falcon 2009-03-14 15:13:53 EDT
Seems to be USB disconnects. I think this is a hardware issue. I will reopen this report if a new mouse does not fix.

dmesg snip

input: HP HP USB WHEEL MOUSE as /devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2.1/1-2.1:1.0/input/input19
input,hidraw1: USB HID v1.00 Mouse [HP HP USB WHEEL MOUSE] on usb-0000:00:1a.7-2.1
usb 1-2.1: New USB device found, idVendor=0458, idProduct=0007
usb 1-2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-2.1: Product: HP USB WHEEL MOUSE
usb 1-2.1: Manufacturer: HP
SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
usb 1-2.1: USB disconnect, address 24
usb 1-2.1: new low speed USB device using ehci_hcd and address 25
usb 1-2.1: configuration #1 chosen from 1 choice
input: HP HP USB WHEEL MOUSE as /devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2.1/1-2.1:1.0/input/input20
input,hidraw1: USB HID v1.00 Mouse [HP HP USB WHEEL MOUSE] on usb-0000:00:1a.7-2.1
usb 1-2.1: New USB device found, idVendor=0458, idProduct=0007
usb 1-2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-2.1: Product: HP USB WHEEL MOUSE
usb 1-2.1: Manufacturer: HP
SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
usb 1-2.1: USB disconnect, address 25
usb 1-2.1: new low speed USB device using ehci_hcd and address 26
usb 1-2.1: configuration #1 chosen from 1 choice
input: HP HP USB WHEEL MOUSE as /devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2.1/1-2.1:1.0/input/input21
input,hidraw1: USB HID v1.00 Mouse [HP HP USB WHEEL MOUSE] on usb-0000:00:1a.7-2.1
usb 1-2.1: New USB device found, idVendor=0458, idProduct=0007
usb 1-2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-2.1: Product: HP USB WHEEL MOUSE
usb 1-2.1: Manufacturer: HP
usb 1-2.1: USB disconnect, address 26
usb 1-2.1: new low speed USB device using ehci_hcd and address 27
usb 1-2.1: configuration #1 chosen from 1 choice
input: HP HP USB WHEEL MOUSE as /devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2.1/1-2.1:1.0/input/input22
input,hidraw1: USB HID v1.00 Mouse [HP HP USB WHEEL MOUSE] on usb-0000:00:1a.7-2.1
usb 1-2.1: New USB device found, idVendor=0458, idProduct=0007
usb 1-2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-2.1: Product: HP USB WHEEL MOUSE
usb 1-2.1: Manufacturer: HP
SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
SELinux: 8192 avtab hash slots, 114512 rules.
SELinux: 8192 avtab hash slots, 114512 rules.
SELinux:  8 users, 11 roles, 2675 types, 121 bools, 1 sens, 1024 cats
SELinux:  73 classes, 114512 rules
usb 1-2.1: USB disconnect, address 27
usb 1-2.1: new low speed USB device using ehci_hcd and address 28
usb 1-2.1: configuration #1 chosen from 1 choice
input: HP HP USB WHEEL MOUSE as /devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2.1/1-2.1:1.0/input/input23
input,hidraw1: USB HID v1.00 Mouse [HP HP USB WHEEL MOUSE] on usb-0000:00:1a.7-2.1
usb 1-2.1: New USB device found, idVendor=0458, idProduct=0007
usb 1-2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-2.1: Product: HP USB WHEEL MOUSE
usb 1-2.1: Manufacturer: HP
SELinux: initialized (dev fuse, type fuse), uses genfs_contexts

Note You need to log in before you can comment on or make changes to this bug.