This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 490243 - xfig crashes on startup with SIGSEGV
xfig crashes on startup with SIGSEGV
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xfig (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 20:21 EDT by Ian Dall
Modified: 2009-03-13 21:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 21:14:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb backtrace (1.52 KB, text/plain)
2009-03-13 20:21 EDT, Ian Dall
no flags Details

  None (edit)
Description Ian Dall 2009-03-13 20:21:25 EDT
Created attachment 335182 [details]
gdb backtrace

Description of problem:
Starting xfig (either xfig-plain or xfig-Xaw3d) causes a segmentation fault.

Version-Release number of selected component (if applicable):
xfig-3.2.5-11.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1.Start xfig
2.
3.
  
Actual results:

$ xfig-plain
Warning: Cannot convert string "7x13bold" to type FontStruct
Warning: Unable to load any usable ISO8859 font
Warning: Unable to load any usable ISO8859 font
Segmentation fault

Expected results:
No segmentation fault

Additional info:

gdb backtrace attached
Comment 1 Ian Dall 2009-03-13 21:14:22 EDT
This turns out to be a mis-configured font server. It is a bit strange, because fslsfonts seemed to show xfs working properly. But reverting to the distributed /etc/X11/fs/config solved the problem.

Note You need to log in before you can comment on or make changes to this bug.