This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 490245 - (device-mapper) device-mapper: Invalidating snapshot: Unable to allocate exception. Buffer I/O error on device dm-0
device-mapper: Invalidating snapshot: Unable to allocate exception. Buffer I/...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: device-mapper-obsolete (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Milan Broz
Fedora Extras Quality Assurance
:
: 735035 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 21:08 EDT by Joshua Covington
Modified: 2013-02-28 23:07 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-14 09:40:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg-2.6.29-0.237.rc7.git4.fc11.x86_64 (49.70 KB, text/plain)
2009-03-13 21:08 EDT, Joshua Covington
no flags Details

  None (edit)
Description Joshua Covington 2009-03-13 21:08:18 EDT
Created attachment 335185 [details]
dmesg-2.6.29-0.237.rc7.git4.fc11.x86_64

Description of problem:
When I work with livecd images and try to copy/move a file bigger than ~150mb in the memory I got the folloing error:

device-mapper: snapshots: Invalidating snapshot: Unable to allocate exception.
Buffer I/O error on device dm-0, logical block 716926
lost page write due to I/O error on dm-0
Buffer I/O error on device dm-0, logical block 716927
lost page write due to I/O error on dm-0
Buffer I/O error on device dm-0, logical block 716928
lost page write due to I/O error on dm-0
Buffer I/O error on device dm-0, logical block 716929
lost page write due to I/O error on dm-0
Buffer I/O error on device dm-0, logical block 716930
lost page write due to I/O error on dm-0
Buffer I/O error on device dm-0, logical block 716931
lost page write due to I/O error on dm-0
Buffer I/O error on device dm-0, logical block 716932
lost page write due to I/O error on dm-0
Buffer I/O error on device dm-0, logical block 716933
lost page write due to I/O error on dm-0
Buffer I/O error on device dm-0, logical block 716934
lost page write due to I/O error on dm-0
Buffer I/O error on device dm-0, logical block 716935
lost page write due to I/O error on dm-0
JBD: Detected IO errors while flushing file data on dm-0
Aborting journal on device dm-0.
ext3_abort called.
EXT3-fs error (device dm-0): ext3_journal_start_sb: Detected aborted journal
Remounting filesystem read-only
JBD: Detected IO errors while flushing file data on dm-0
__journal_remove_journal_head: freeing b_committed_data
__ratelimit: 810 callbacks suppressed
Buffer I/O error on device dm-0, logical block 589841


Version-Release number of selected component (if applicable):
all kernels
the attached dmesg is from 2.6.29-0.237.rc7.git4.fc11.x86_64


How reproducible:
1.use a standard livecd image and try to install gcc and libgcj
or
2. try to recompile (using livecd image) the proprietary ati fglrx driver from rpmfusion
or
3 try to copy a file > 150mb from usb to any directory in the live image

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
It looks like the kernel locks itself up and remaps everything read-only. After this no read/write operations are allowed. I have 4GB ram and this should be more than enough for basic operations.


Expected results:
Everything should work fine. If the kernel sees that there isn't enough memory (4gb in this case) it shouldn't allow the operation but not remap everything read only.


Additional info:
I've attached the dmesg from 2.6.29-0.237.rc7.git4.fc11.x86_64.
Comment 1 Milan Broz 2009-03-14 09:40:10 EDT
(In reply to comment #0)

device-mapper: snapshots: Invalidating snapshot: Unable to allocate exception.
> 3 try to copy a file > 150mb from usb to any directory in the live image

This is expected - LiveCD runs in dm snapshot, if the snapshot gets full, there is no place to store new changed blocks and system disable the snapshot.
Because here it is root fs in snapshot, it stops working completely.
It cannot remap to read-only here, because filesystem need to store metadata too - and the snapshot is just full. The snapshot has fixed size defined in the LiveCD itself.

Just do not copy such big data into directory on root (in snapshot), but work in the directory mounted from usb disk directly and it will work.
Or, if you have really lot of RAM, create new ramdisk, mount it to some directory and use that.
Comment 2 Joshua Covington 2009-03-14 11:18:24 EDT
rpmbuild works in /var/tmp-*** and this is causing this behaviour. 4gb ram should be enogh but how to create an new ramdisk?
I also reraly use the / directory. Almost anything is in /home/livesuser/ and when copying something there I got this lockup. How to remap the /var and the /tmp directories to a new ram disk?
Comment 3 Milan Broz 2009-03-14 13:40:41 EDT
You can override buildroot & installroot for rpmbuild, you can mount real disk for the real buildroot or use tmpfs there...

I think change of rpm build directories is decribed here  http://fedoraproject.org/wiki/PackageMaintainers/CreatingPackageHowTo#Setting_up_your_system_and_account
Comment 4 Eric Sandeen 2011-09-07 10:15:55 EDT
*** Bug 735035 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.