Bug 490274 - NetworkManager doesn't handle aliases properly
NetworkManager doesn't handle aliases properly
Status: CLOSED DUPLICATE of bug 443968
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-14 12:10 EDT by Pierre Ossman
Modified: 2009-03-16 13:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 13:18:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2009-03-14 12:10:45 EDT
Systems that have ifcfg-eth#:# do not work properly with NM. It only sets a single address, and not even the primary one, completely breaking the setup.
Comment 1 Jessica Sterling 2009-03-14 21:54:34 EDT
Hello, which version of NetworkManager do you currently have installed?  Could you also attach your virtual interface configuration files?  Thank you!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Pierre Ossman 2009-03-15 06:58:51 EDT
[root@yggdrasil ~]# rpm -q NetworkManager
NetworkManager-0.7.0.99-3.fc10.x86_64
[root@yggdrasil ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet
DEVICE=eth0
BOOTPROTO=static
HWADDR=00:1D:92:F3:AE:27
ONBOOT=yes
IPADDR=10.8.0.24
NETMASK=255.255.255.0
[root@yggdrasil ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0:0
DEVICE=eth0:0
IPADDR=10.8.0.1
NETMASK=255.255.255.0
Comment 3 Dan Williams 2009-03-16 13:18:08 EDT

*** This bug has been marked as a duplicate of bug 443968 ***

Note You need to log in before you can comment on or make changes to this bug.