Bug 490289 - Duplicity backups to slow ssh servers time out
Duplicity backups to slow ssh servers time out
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: duplicity (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-14 16:44 EDT by Jon Levell
Modified: 2009-04-06 16:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.5.12-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-21 11:51:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Levell 2009-03-14 16:44:53 EDT
Using the version of duplicity that is currently packaged in F10 (0.5.06), backups of a 60G directory to an underpowered Linux ssh server (an NSLU2) regularly timed out damaging the backup.

When I updated to 0.5.09 (which when I started using it was the latest upstream release) the problem went away. I think the problem was fixed by:

patch #6730: Fix timing out for SSH backend
https://savannah.nongnu.org/patch/?6730
In v0.5.07.


I used the following modified spec file (I updated more than just the version but even after my modifications there were still rpmlint warnings):
http://www.coralbark.net/fedora/duplicity/duplicity.spec

Upstream has recently released 0.5.11, could the version packaged in Fedora be updated please?
Comment 1 Robert Scheck 2009-03-21 11:51:35 EDT
Thank you for your report.

From a diff between duplicity's spec file of version 0.5.06 in CVS and yours I 
were not able to see a real fix/modification except some tiny rumblings, sorry.
Looks like your spec file based on 0.4.12-2, but all Fedora and EPEL branches
are already (or at least should be, if you're updating your system regulary) at 
0.5.06-2.

Nevertheless I've updated the package to 0.5.12, released a few days ago. Please 
vote for it accordingly in bodhi, thank you.
Comment 2 Fedora Update System 2009-03-21 11:52:16 EDT
duplicity-0.5.12-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/duplicity-0.5.12-1.fc9
Comment 3 Fedora Update System 2009-03-21 11:52:19 EDT
duplicity-0.5.12-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/duplicity-0.5.12-1.fc10
Comment 4 Fedora Update System 2009-04-06 16:28:05 EDT
duplicity-0.5.12-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2009-04-06 16:32:43 EDT
duplicity-0.5.12-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.