Bug 490303 - libudev0 should be renamed to libudev or udev-libs
libudev0 should be renamed to libudev or udev-libs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-14 21:37 EDT by Kevin Kofler
Modified: 2009-06-30 10:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 06:17:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2009-03-14 21:37:00 EDT
The libudev0 subpackage should be renamed to libudev (or possibly udev-libs, which is the common convention, but in this case libvolume_id is separate, so libudev is probably the better option). There should be no version suffix for the default version of a library, and in this case the suffix is even more pointless because libudev.so.0 is the _only_ version of the library.

Including the soname version in the package name is not useful with RPM because that's what the automatic soname dependencies are for.
Comment 1 Bug Zapper 2009-06-09 08:14:34 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Harald Hoyer 2009-06-30 06:17:57 EDT
done in rawhide
Comment 3 Kevin Kofler 2009-06-30 10:44:40 EDT
OK, but now you added libgudev1 which also shouldn't have that suffix.
Comment 4 Harald Hoyer 2009-06-30 10:58:43 EDT
yes it should, because it has the version number in the library name.

Note You need to log in before you can comment on or make changes to this bug.