Red Hat Bugzilla – Bug 490303
libudev0 should be renamed to libudev or udev-libs
Last modified: 2009-06-30 10:58:43 EDT
The libudev0 subpackage should be renamed to libudev (or possibly udev-libs, which is the common convention, but in this case libvolume_id is separate, so libudev is probably the better option). There should be no version suffix for the default version of a library, and in this case the suffix is even more pointless because libudev.so.0 is the _only_ version of the library.
Including the soname version in the package name is not useful with RPM because that's what the automatic soname dependencies are for.
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.
More information and reason for this action is here:
done in rawhide
OK, but now you added libgudev1 which also shouldn't have that suffix.
yes it should, because it has the version number in the library name.