Bug 490322 - bash no longer complete filenames with spaces in them
bash no longer complete filenames with spaces in them
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bash-completion (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-15 05:39 EDT by Scott Tsai
Modified: 2014-01-12 19:08 EST (History)
6 users (show)

See Also:
Fixed In Version: 1.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 15:05:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
workaround patch (707 bytes, patch)
2009-03-15 06:00 EDT, Yanko Kaneti
no flags Details | Diff

  None (edit)
Description Scott Tsai 2009-03-15 05:39:43 EDT
Description of problem:
bash in rawhide no longer offers completion for a directory named 'a b c' when I type "a\ TAB". It used to on Fedora 10.

Version-Release number of selected component (if applicable):
bash-4.0-3.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. mkdir 'a b c'
2. In an interactive shell type: ls a\ TAB

  
Actual results:
No completion offered.

Expected results:
bash offers the completion:
ls a\ b\ c/

Additional info:
Comment 1 Yanko Kaneti 2009-03-15 06:00:46 EDT
Created attachment 335244 [details]
workaround patch

I am using this workaround patch for this particular issue. Not sure if it fits in the filedir logic there. Worksforme..
Comment 2 Yanko Kaneti 2009-03-15 06:06:20 EDT
Ugh, sorry, I just notcied this is against bash. Plain bash filename with spaces completion works for me here. Current bash-completion in rawhide, messes up with it, and that previous patch is for it.
Comment 3 Scott Tsai 2009-03-15 06:35:56 EDT
Yanko, I uninstalled bash-completion and the bug indeed went away. Thanks! I'll re-file this bug against bash-completion then.
Comment 4 Scott Tsai 2009-03-15 06:40:00 EDT
Completion fails on filenames with spaces in them when:
bash-completion-20080705-3.20090211git47d0c5b.noarch
is installed. It works in plain bash.
Comment 5 Ville Skyttä 2009-03-15 16:03:47 EDT
I can't reproduce with bash 3.2 and don't have a bash 4 setup available right now.  Bug forwarded upstream at http://alioth.debian.org/tracker/index.php?func=detail&aid=311544&group_id=100114&atid=413095
Comment 6 Scott Tsai 2009-04-07 13:26:45 EDT
I updated bash-completion (bash-completion-1.0-1.fc11.noarch, bash-4.0-5.fc11.x86_64) and this bug is still present.

From Ville's upstream bug report, I understand we're waiting for a change effecting 'quote_readline' in bash, just wanted to see if you guys decided to integrate the workaround before that's fixed ;)
Comment 7 Ville Skyttä 2009-04-07 13:48:09 EDT
The workaround would obviously be only applicable to bash 4.x.  Meanwhile, a different fix has been committed to upstream master branch.  It should have pretty much the same effect as the patch in comment 1, but could you test it anyway just to be sure and let me know if it fixes the issue?

http://git.debian.org/?p=bash-completion/bash-completion.git;a=commitdiff_plain;h=1421e55aac075e13491cd212b796bdd453214a2c
Comment 8 Scott Tsai 2009-04-07 14:09:27 EDT
The patch works for my test case :)
Comment 9 Ville Skyttä 2009-04-07 15:05:58 EDT
Thanks for testing.  The patch is included in 1.0-2.

Note You need to log in before you can comment on or make changes to this bug.