This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 490340 - yumex UI doesn't get drawn when a networking op. is in progress
yumex UI doesn't get drawn when a networking op. is in progress
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-15 09:59 EDT by Ilyes Gouta
Modified: 2009-03-16 04:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 04:15:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ilyes Gouta 2009-03-15 09:59:00 EDT
Description of problem:

The GUI doesn't get updated/redrawn when yumex is downloading the repo. description file or when downloading a given package. The symptom I'm trying to describe is just like yumex is using a blocking network operations (send/receive) in the same code path of the GUI event processing and drawing code. Any delay caused by a blocking receive() operation will lead to the GUI to stop responding and not being redrawn for a while. It's very a annoying behavior for a modern application.

Version-Release number of selected component (if applicable):

Yumex: 2.0.5

How reproducible:

Just watch it in action. Try resizing the frame while yumex is downloading the repo. specs and downloading packages.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Lauridsen 2009-03-16 04:15:22 EDT
I it a known problem, the yumex gui get refreshed everytime there is some callback from the yum backend, and in some cases the callbacks are not frequent enough, so the gui looks frozen for a period of time, but it always wake up again :)
I work on it in a future version of yum, but it is a total rewrite, so it is in an very easy state, so it will take a while to get it done. 

I close the bug, because it cant be fix in the current yumex codestream.
Comment 2 Ilyes Gouta 2009-03-16 04:53:40 EDT
Is it possible to place all the yum backend processing in a separate thread? Good to know that a newer version is coming along!

Regards,
Ilyes Gouta.

Note You need to log in before you can comment on or make changes to this bug.