Bug 490377 - With VRGB font smoothing, qt4 displays garbage
With VRGB font smoothing, qt4 displays garbage
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-15 16:55 EDT by Adam Goode
Modified: 2009-04-25 13:27 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.2.2-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 21:06:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Qt4 application with RGB subpixel (20.88 KB, image/png)
2009-03-15 16:55 EDT, Adam Goode
no flags Details
Qt4 application with VRGB subpixel (24.76 KB, image/png)
2009-03-15 16:55 EDT, Adam Goode
no flags Details

  None (edit)
Description Adam Goode 2009-03-15 16:55:12 EDT
Created attachment 335275 [details]
Qt4 application with RGB subpixel

Description of problem:
When VRGB is selected in subpixel font smoothing options in Gnome, Qt4 applications display garbage instead of text.


Version-Release number of selected component (if applicable):
qt-4.5.0-3.fc11.x86_64


How reproducible:
Always.


Steps to Reproduce:
1. Select VRGB.
2. Run psi or lmms.

  
Actual results:
Garbage fonts.
Comment 1 Adam Goode 2009-03-15 16:55:45 EDT
Created attachment 335276 [details]
Qt4 application with VRGB subpixel
Comment 2 Kevin Kofler 2009-03-15 17:01:54 EDT
Just to ask the obvious: you do have freetype-freeworld or some other freetype build with subpixel antialiasing support, right?
Comment 3 Rex Dieter 2009-03-15 18:53:13 EDT
What X video driver are you using?
Comment 4 Adam Goode 2009-03-15 19:36:49 EDT
I do not have freetype-freeworld, this is the default Fedora 11 freetype. It DOES appear to have subpixel rendering: I can see it with xmag.

I am using xorg-x11-drv-ati (r300 radeon, not using KMS).
Comment 5 Kevin Kofler 2009-03-15 20:00:44 EDT
This is interesting, I just checked, subpixel antialiasing is disabled in F9, but got reenabled in F10 and devel.
Comment 6 Kevin Kofler 2009-04-11 03:42:04 EDT
Behdad said enabling subpixel antialiasing in the Fedora freetype was a mistake (because of patent issues), it's disabled again in current Rawhide and there's also a new F10 freetype build with it disabled (but I don't think it got pushed out). Still, Qt should not display garbage with it...

This is also reproducible with Intel graphics according to:
https://www.redhat.com/archives/fedora-list/2009-April/msg01110.html
Comment 7 José Matos 2009-04-14 13:56:52 EDT
I was using an r300 with KMS as it can be seen here:
http://lists.fedoraproject.org/pipermail/fedora-kde/2009-February/001479.html

The fix was to remove the hinting:
http://lists.fedoraproject.org/pipermail/fedora-kde/2009-February/001624.html
Comment 8 Rex Dieter 2009-04-14 14:28:24 EDT
Interesting, enabled full font hinting here in systemsettings, but I (still) can't reproduce.
Comment 9 Rex Dieter 2009-04-14 14:32:35 EDT
nevermind, reading closer (sorry), missed the vrgb part.  Confirmed universally broken here, regardless of hinting.
Comment 10 Rex Dieter 2009-04-14 14:42:43 EDT
confirmed to that vgbr is broken likewise.
Comment 11 Rex Dieter 2009-04-14 15:48:52 EDT
* Tue Apr 14 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.0-14
- fix vrgb/vgbr corruption, disable QT_USE_FREETYPE_LCDFILTER (#490377)
Comment 12 Fedora Update System 2009-04-15 14:02:23 EDT
kdeutils-4.2.2-2.fc10, kdetoys-4.2.2-2.fc10, kdesdk-4.2.2-2.fc10, kdeplasma-addons-4.2.2-2.fc10, kdeedu-4.2.2-1.fc10, kdebase-runtime-4.2.2-3.fc10, kdebase-4.2.2-2.fc10, kdeartwork-4.2.2-3.fc10, kdeadmin-4.2.2-2.fc10, kdeaccessibility-4.2.2-1.fc10, sigen-0.1.1-1.fc10, qgit-2.2-4.fc10.1, psi-0.12.1-2.fc10, kde-plasma-weather-1.0.0-3.fc10, arora-0.6-1.fc10, kde-l10n-4.2.2-1.fc10, kdegraphics-4.2.2-3.fc10, kde-i18n-3.5.10-4.fc10, kdepimlibs-4.2.2-3.fc10, oxygen-icon-theme-4.2.2-1.fc10, kdebindings-4.2.2-2.fc10, kdepim-4.2.2-3.fc10, konq-plugins-4.2.2-1.fc10, kdemultimedia-4.2.2-2.fc10, kdenetwork-4.2.2-1.fc10, kdegames-4.2.2-6.fc10, kdelibs-4.2.2-5.fc10, qjackctl-0.3.3-3.fc10, qsynth-0.3.3-4.fc10, kdebase-workspace-4.2.2-3.fc10, qt-4.5.0-14.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdeedu kdebase-runtime kdebase kdeartwork kdeadmin kdeaccessibility sigen qgit psi kde-plasma-weather arora kde-l10n kdegraphics kde-i18n kdepimlibs oxygen-icon-theme kdebindings kdepim konq-plugins kdemultimedia kdenetwork kdegames kdelibs qjackctl qsynth kdebase-workspace qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3389
Comment 13 Fedora Update System 2009-04-17 14:05:36 EDT
kdeutils-4.2.2-2.fc10, kdetoys-4.2.2-2.fc10, kdesdk-4.2.2-2.fc10, kdeplasma-addons-4.2.2-2.fc10, kdeedu-4.2.2-1.fc10, kdebase-4.2.2-2.fc10, kdeartwork-4.2.2-3.fc10, kdeadmin-4.2.2-2.fc10, kdeaccessibility-4.2.2-1.fc10, sigen-0.1.1-1.fc10, qgit-2.2-4.fc10.1, psi-0.12.1-2.fc10, kde-plasma-weather-1.0.0-3.fc10, arora-0.6-1.fc10, kde-l10n-4.2.2-1.fc10, kdegraphics-4.2.2-3.fc10, kde-i18n-3.5.10-4.fc10, kdepimlibs-4.2.2-3.fc10, oxygen-icon-theme-4.2.2-1.fc10, kdebindings-4.2.2-2.fc10, kdepim-4.2.2-3.fc10, konq-plugins-4.2.2-1.fc10, kdemultimedia-4.2.2-2.fc10, kdenetwork-4.2.2-1.fc10, kdegames-4.2.2-6.fc10, kdelibs-4.2.2-5.fc10, qjackctl-0.3.3-3.fc10, qsynth-0.3.3-4.fc10, kdebase-workspace-4.2.2-3.fc10, qt-4.5.0-14.fc10, kdebase-runtime-4.2.2-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdeedu kdebase kdeartwork kdeadmin kdeaccessibility sigen qgit psi kde-plasma-weather arora kde-l10n kdegraphics kde-i18n kdepimlibs oxygen-icon-theme kdebindings kdepim konq-plugins kdemultimedia kdenetwork kdegames kdelibs qjackctl qsynth kdebase-workspace qt kdebase-runtime'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3389
Comment 14 Fedora Update System 2009-04-21 21:05:45 EDT
kdeutils-4.2.2-2.fc10, kdetoys-4.2.2-2.fc10, kdesdk-4.2.2-2.fc10, kdeplasma-addons-4.2.2-2.fc10, kdeedu-4.2.2-1.fc10, kdebase-4.2.2-2.fc10, kdeartwork-4.2.2-3.fc10, kdeadmin-4.2.2-2.fc10, kdeaccessibility-4.2.2-1.fc10, sigen-0.1.1-1.fc10, qgit-2.2-4.fc10.1, psi-0.12.1-2.fc10, kde-plasma-weather-1.0.0-3.fc10, arora-0.6-1.fc10, kde-l10n-4.2.2-1.fc10, kdegraphics-4.2.2-3.fc10, kde-i18n-3.5.10-4.fc10, kdepimlibs-4.2.2-3.fc10, oxygen-icon-theme-4.2.2-1.fc10, kdebindings-4.2.2-2.fc10, kdepim-4.2.2-3.fc10, konq-plugins-4.2.2-1.fc10, kdemultimedia-4.2.2-2.fc10, kdenetwork-4.2.2-1.fc10, kdegames-4.2.2-6.fc10, kdebase-workspace-4.2.2-3.fc10, qt-4.5.0-14.fc10, kdebase-runtime-4.2.2-4.fc10, qjackctl-0.3.4-1.fc10, qsynth-0.3.3-6.fc10, kdelibs-4.2.2-7.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Rex Dieter 2009-04-25 13:27:23 EDT
fyi, freetype lcd_filter for vrgb/vgbr is fixed in qt-4.5.1.

Note You need to log in before you can comment on or make changes to this bug.