This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 490380 - Review Request: qt-creator - Lightweight and cross-platform IDE for Qt
Review Request: qt-creator - Lightweight and cross-platform IDE for Qt
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-15 19:09 EDT by Itamar Reis Peixoto
Modified: 2014-02-04 01:16 EST (History)
6 users (show)

See Also:
Fixed In Version: qt-creator-1.3.1-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 17:23:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rdieter: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)
spec file, fixing the icon (2.88 KB, application/octet-stream)
2009-04-25 16:32 EDT, Muayyad Alsadi
no flags Details

  None (edit)
Description Itamar Reis Peixoto 2009-03-15 19:09:10 EDT
Spec URL: http://ispbrasil.com.br/qtcreator/qt-creator.spec
SRPM URL: http://ispbrasil.com.br/qtcreator/qt-creator-1.0.0-1.fc11.src.rpm


Description: 
Qt Creator (previously known as Project Greenhouse) is a new,
lightweight, cross-platform integrated  development environment (IDE)
designed to make development with the Qt application framework
even faster and easier.


koji scratch build

http://koji.fedoraproject.org/koji/taskinfo?taskID=1242645
Comment 1 Rex Dieter 2009-03-15 19:28:33 EDT
What's the purpose of the patches:
no-docu.diff
disable_private_header_check.patch

Please document it, in the specfile.
Comment 2 Kevin Kofler 2009-03-15 19:44:12 EDT
no-docu.diff should not be needed now that qdoc3 is included in qt-devel. As for disable_private_header_check.patch, Lukáš Tinkl has a package without it which apparently builds. So please try building it without these patches.

QTDIR=/usr/lib64/qt4 is not valid (you have to use %{_qt4_prefix} instead, there's no lib64 on 32-bit platforms) and should not be needed at all.

Stuff getting installed to hardcoded /usr/lib/qtcreator also looks broken to me. If this is target-specific stuff, it should go to %{_libdir}, not /usr/lib.
Comment 3 Itamar Reis Peixoto 2009-03-15 22:09:34 EDT
(In reply to comment #2)
> no-docu.diff should not be needed now that qdoc3 is included in qt-devel.

--> I will check this, but for me the doc still doesn't build's


 
> As for disable_private_header_check.patch, Lukáš Tinkl has a package without it
> which apparently builds. So please try building it without these patches.

--> the patch is required or the ui editor not work
--> the patch comes from qt-creator git

--> http://labs.trolltech.com/gitweb?p=qt-creator;a=commitdiff;h=f3f20d96bdfb5266cc25ac91ae0def8a33875a81




> QTDIR=/usr/lib64/qt4 is not valid (you have to use %{_qt4_prefix} instead,
> there's no lib64 on 32-bit platforms) and should not be needed at all.
> 
> Stuff getting installed to hardcoded /usr/lib/qtcreator also looks broken to
> me. If this is target-specific stuff, it should go to %{_libdir}, not /usr/lib.  

--> qt-creator is broken :-), I am looking for a solution about this.
Comment 5 Kevin Kofler 2009-03-18 03:14:30 EDT
"BuildRequires:  qt-devel >= 4.5.0" will not work, because it's missing the Epoch (i.e. 1:4.5.0).

I recommend using
BuildRequires:  qt4-devel >= 4.5.0
instead. (These virtual Provides have no Epoch.)
Comment 6 Kevin Kofler 2009-03-18 03:19:54 EDT
And your License tag is incorrect. You claim it's LGPLv2+, it's actually "LGPLv2 with exceptions". (They allow only version 2.1 and they have the same exception about inlines and templates as for Qt itself.)
Comment 8 Rex Dieter 2009-03-25 08:26:17 EDT
I'll take a look, but packaging-wise this is pretty simple.  Offhand, some of the patches could be reworked to be more upstream'able, but that the can be addressed post-review. 

sources match upstream:
5478124035d80a90e66a3db67ab4477a  qt-creator-1.0.0-src.zip

rpmlint output:

$ rpmlint *.rpm
qt-creator.x86_64: W: devel-file-in-non-devel-package /usr/share/qtcreator/templates/qt4project/mywidget.cpp
qt-creator.x86_64: W: devel-file-in-non-devel-package /usr/share/qtcreator/templates/qt4project/mywidget.h  
qt-creator.x86_64: W: devel-file-in-non-devel-package /usr/share/qtcreator/templates/qt4project/main.cpp    
qt-creator.x86_64: W: devel-file-in-non-devel-package /usr/share/qtcreator/templates/qt4project/mywidget_form.cpp                                                                                                           
qt-creator.x86_64: W: devel-file-in-non-devel-package /usr/lib64/qtcreator/libCPlusPlus.so                    
qt-creator.x86_64: W: devel-file-in-non-devel-package /usr/lib64/qtcreator/libUtils.so                        
qt-creator.x86_64: W: devel-file-in-non-devel-package /usr/lib64/qtcreator/libAggregation.so                  
qt-creator.x86_64: W: devel-file-in-non-devel-package /usr/lib64/qtcreator/libQtConcurrent.so                 
qt-creator.x86_64: W: devel-file-in-non-devel-package /usr/lib64/qtcreator/libExtensionSystem.so              
qt-creator.x86_64: W: devel-file-in-non-devel-package /usr/share/qtcreator/templates/qt4project/mywidget_form.h                                                                                                             
qt-creator.x86_64: W: devel-file-in-non-devel-package /usr/share/qtcreator/gdbmacros/gdbmacros.cpp            
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/bin/qtcreator ['$ORIGIN/../lib64/qtcreator']         
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/libQtConcurrent.so.1.0.0 ['$ORIGIN/../lib64/qtcreator']                                                                                            
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/libExtensionSystem.so.1.0.0 ['$ORIGIN/../lib64/qtcreator']                                                                                         
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/libCPlusPlus.so.1.0.0 ['$ORIGIN/../lib64/qtcreator']                                                                                               
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/libAggregation.so.1.0.0 ['$ORIGIN/../lib64/qtcreator']                                                                                             
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libQuickOpen.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']                                                                           
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libDebugger.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']                                                                            
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libCppTools.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']                                                                            
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libProjectExplorer.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']                                                                     
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libQt4ProjectManager.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']                                                                   
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libDesigner.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']                                                                            
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libTextEditor.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']                                                                          
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libCore.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']                                                                                
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libCMakeProjectManager.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']                                                                 
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libQtScriptEditor.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']                                                                      
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libBinEditor.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']                                                                           
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libHelp.so ['$ORIGIN','$ORIGIN/..', '$ORIGIN/../..']
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libVCSBase.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libFind.so ['$ORIGIN','$ORIGIN/..', '$ORIGIN/../..']
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libPerforce.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libFakeVim.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libResourceEditor.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libSubversion.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libBookmarks.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libCppEditor.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/plugins/Nokia/libScmGit.so ['$ORIGIN', '$ORIGIN/..', '$ORIGIN/../..']
qt-creator.x86_64: E: binary-or-shlib-defines-rpath /usr/lib64/qtcreator/libUtils.so.1.0.0 ['$ORIGIN/../lib64/qtcreator']
3 packages and 0 specfiles checked; 27 errors, 11 warnings.

For now, I'm going to be lenient with the rpaths identified here, but it will be worth investigating on removing some/all of these.
The non-devel package warnings are mostly harmless (qt-creator is a developer tool after all).

%files: ok

License: ok

builds: ok (koji)

scriptlets: ldconfig isn't needed here, need to add 'update-desktop-database', but that's minor, can fix fixed post-review.

.desktop files: passable, can use some work post-review too (for example, Icon= is wrong/doesn't work)


APPROVED.
Comment 9 Kevin Kofler 2009-03-25 12:01:45 EDT
> The non-devel package warnings are mostly harmless (qt-creator is a developer
> tool after all).

For the .cpp and .h files, that's the right argument. For the .so files, the right argument is that those are plugins which are most likely dlopened and that they are in an application-specific subdirectory. Either way, these are OK.

The rpaths are there so the libraries are found in the application-specific subdirectory. This sounds like a valid use of rpath to me (even though our guidelines frown upon it).
Comment 10 Itamar Reis Peixoto 2009-03-26 19:12:08 EDT
New Package CVS Request
=======================
Package Name: qt-creator
Short Description: Lightweight and cross-platform IDE for Qt
Owners: itamarjp
Branches: 
InitialCC:
Comment 11 Kevin Fenzi 2009-03-27 16:19:23 EDT
cvs done.
Comment 12 Muayyad Alsadi 2009-04-25 16:32:48 EDT
Created attachment 341325 [details]
spec file, fixing the icon

I noticed that the icons are put in %{_datadir}/pixmaps/qtcreator_logo_*.png

so I added links to them in %{_datadir}/icons/hicolor/*/apps/Nokia-QtCreator.png
Comment 13 Itamar Reis Peixoto 2009-04-25 18:15:52 EDT
(In reply to comment #12)
thanks for the patch, applyed

---------------------------------------------------------------------

qt 4.5.1 has been pushed for F-9 and F-10, I like to make qt-creator available for these branches too


Package Change Request
======================
Package Name: qt-creator
New Branches: F-9 F-10 
Owners: itamarjp
Comment 14 Kevin Fenzi 2009-04-27 01:17:49 EDT
cvs done.
Comment 15 Fedora Update System 2009-04-27 13:26:00 EDT
qt-creator-1.1.0-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/qt-creator-1.1.0-2.fc9
Comment 16 Fedora Update System 2009-04-27 13:26:49 EDT
qt-creator-1.1.0-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/qt-creator-1.1.0-2.fc10
Comment 17 Fedora Update System 2009-04-27 13:27:49 EDT
qt-creator-1.1.0-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qt-creator-1.1.0-2.fc11
Comment 18 Fedora Update System 2009-04-27 17:22:56 EDT
qt-creator-1.1.0-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2009-04-27 17:26:50 EDT
qt-creator-1.1.0-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2009-05-09 00:15:32 EDT
qt-creator-1.1.0-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Dave Johansen 2014-01-06 00:02:38 EST
Package Change Request
======================
Package Name: qt-creator
New Branches: el6
Owners: daveisfera
InitialCC: itamarjp

Adding Qt Creator to EPEL for EL6 so it can be used for development on EL6 machines in addition to Fedora machines.
Comment 22 Gwyn Ciesla 2014-01-06 08:09:07 EST
Any comments from the Fedora maintainers?
Comment 23 Rex Dieter 2014-01-06 08:30:50 EST
Sorry, it was ACK'd via private mail

(that said, I'm not sure how well qt-creator will build/work with el6's old qt4 version)
Comment 24 Dave Johansen 2014-01-06 10:01:08 EST
I have modified the .spec file for qt-creator 1.3 to build against the Qt 4 that comes with EL6. Also, I have built qt-creator 3.0 against the Qt 5 that was recently added to the EPEL and I'm working on finishing up the .spec file for that.

My plan was to release the 1.3 build for the time being and then update it to 3.0 once I had that .spec file finished. I didn't go over the details of the plan, but I asked itamarjp if it was ok if I opened a branch for EL6 and he said that it was. I'm asking to be the owner/maintainer of this and I'm not asking someone else to do any of the work, so I don't get why there's so much hesitation/resistance to this.
Comment 25 Rex Dieter 2014-01-06 10:33:54 EST
Dave, thanks for your efforts.

cvs-admins are just doing their due-diligence to ensure other existing maintainers condone the branching (which was not yet documented, here or otherwise).  It is now.
Comment 26 Dave Johansen 2014-01-06 10:52:07 EST
Ok, that makes sense. Could whatever that documentation process needs to be please be added to https://fedoraproject.org/wiki/Package_SCM_admin_requests#Package_Change_Requests_for_existing_packages because those instructions are all that people like me have to go by and it didn't say anything about how to document that "existing maintainers condone the branching", so I just assumed that getting permission and then CCing the owner here was good enough.
Comment 27 Rex Dieter 2014-01-06 10:58:54 EST
You got permission, yes, good.  The only problem was that the permission was not verifiable or documented anywhere.
Comment 28 Rex Dieter 2014-01-06 11:08:11 EST
Much of what was discussed here is covered on
http://fedoraproject.org/wiki/EPEL/FAQ#Questions_specific_to_existing_Fedora_contributors

In particular, in your original request, you didn't explicitly mention *why* you were becoming the el6 branch maintainer (as opposed to letting existing maintainers do it).

Though, this use-case, of someone new/different maintaining a epel-6 branch separately, could benefit from being listed as a scenario in the aforementioned link, to help reduce possible confusion.
Comment 29 Rex Dieter 2014-01-06 11:30:42 EST
(resetting fedora-cvs flag)
Comment 30 Gwyn Ciesla 2014-01-06 11:42:03 EST
Still looking for the aforementioned documentation.
Comment 31 Itamar Reis Peixoto 2014-01-06 12:25:04 EST
(In reply to Dave Johansen from comment #21)

Package Change Request
======================
Package Name: qt-creator
New Branches: el6
Owners: daveisfera 
InitialCC: itamarjp jreznik ltinkl rdieter
 
> Adding Qt Creator to EPEL for EL6 so it can be used for development on EL6
> machines in addition to Fedora machines.

Can we create a new branch for el-6 ?

Dave, Can you also help maintaining the existing branches for qt-creator, Can you request access in pkgdb for existing branches ? Can you share ownership for el6 branch with current folks ?
Comment 32 Gwyn Ciesla 2014-01-06 13:22:22 EST
Git done (by process-git-requests).
Comment 33 Dave Johansen 2014-01-12 23:30:39 EST
In reply to comment #31:
> Can you also help maintaining the existing branches for qt-creator?
Sure.

> Can you request access in pkgdb for existing branches ?
Done. I'm not sure what approveacls is, but I'm guessing that it's the right to change permissions or something along those lines and I didn't request that, but I can, if you'd like me to.

> Can you share ownership for el6 branch with current folks ?
Done. I didn't give approveacls, but I can if you'd like me to.
Comment 34 Fedora Update System 2014-01-16 22:36:27 EST
qt-creator-1.3.1-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/qt-creator-1.3.1-4.el6
Comment 35 Fedora Update System 2014-02-03 15:49:28 EST
qt-creator-1.3.1-4.el6 has been pushed to the Fedora EPEL 6 stable repository.

Note You need to log in before you can comment on or make changes to this bug.