Bug 490383 - compiz-0.7.8-15 and -16 fail to start on Thinkpad X200, w/ Intel graphics
compiz-0.7.8-15 and -16 fail to start on Thinkpad X200, w/ Intel graphics
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-15 19:26 EDT by Tom London
Modified: 2009-03-16 10:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 10:27:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "dpyinfo -queryExtensions" (20.02 KB, text/plain)
2009-03-15 22:20 EDT, Tom London
no flags Details
Output of "glxinfo" (14.48 KB, text/plain)
2009-03-16 09:25 EDT, Tom London
no flags Details
Output of "LIBGL_ALWAYS_INDIRECT=1 glxinfo" (14.02 KB, text/plain)
2009-03-16 09:26 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2009-03-15 19:26:34 EDT
Description of problem:
The latest 2 compiz packages "fail to start" when I run "System->preferences->desktop-effects"

Here is what I find in ~/.xsession-errors:

compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
compiz (core) - Fatal: No manageable screens found on display :0.0
gtk-window-decorator: Screen 0 on display ":0.0" already has a decoration manager; try using the --replace option to replace the current decoration manager.

I used to have to pass "LIBGL_ALWAYS_INDIRECT=1", that (or something similar) needed again?

Version-Release number of selected component (if applicable):
compiz-0.7.8-15.fc11.x86_64 and -16  (-gnome too).

How reproducible:
Every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-03-15 22:20:55 EDT
Created attachment 335286 [details]
Output of "dpyinfo -queryExtensions"

Not sure its useful, but attached is output of "xdpyinfo -queryExtensions"

I tried running "LIBGL_ALWAYS_INDIRECT=1 desktop-effects", but that exited/failed in the same way as above.
Comment 2 Tom London 2009-03-16 09:25:00 EDT
Created attachment 335343 [details]
Output of "glxinfo"

Output of "glxinfo", produced when running compiz-0.7.8-14.fc11.x86_64
Comment 3 Tom London 2009-03-16 09:26:09 EDT
Created attachment 335345 [details]
Output of "LIBGL_ALWAYS_INDIRECT=1 glxinfo"

Output of "LIBGL_ALWAYS_INDIRECT=1 glxinfo" when running compiz-0.7.8-14.fc11.x86_64
Comment 4 Tom London 2009-03-16 09:30:30 EDT
I should add that the above were produce while booted with "nomodeset nopat"
Comment 5 Adel Gadllah 2009-03-16 10:06:46 EDT
Should be fixed in compiz-0.7.8-17.fc11
Comment 6 Tom London 2009-03-16 10:22:48 EDT
Yup.  

compiz-0.7.8-17.fc11 "works for me".

Note You need to log in before you can comment on or make changes to this bug.