This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 490398 - lv2core needs update, also F-10 build is missing
lv2core needs update, also F-10 build is missing
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lv2core (Show other bugs)
10
All Linux
high Severity medium
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-16 00:11 EDT by Orcan Ogetbil
Modified: 2009-04-13 15:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.0-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 10:01:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orcan Ogetbil 2009-03-16 00:11:52 EDT
I believe that this package should be noarch and the .pc file should go to
/usr/share/pkgconfig .

The files %{_datadir}/lv2 that are in the main package are actually devel
files. They are templates to write lv2 plugins and are not needed during
runtime. So only a devel package should be generated from the SRPM.

Also, I found an F-10 build in koji, but apparently it was never pushed to bodhi.

Additionally, there is a new upstream version. I asked for pkgdb access to
fix these issues.
Comment 1 Michael Schwendt 2009-03-16 05:08:38 EDT
> I believe that this package should be noarch

That would make it necessary to alter/redefine the LV2 path, which by default points into %_libdir


> The files %{_datadir}/lv2 that are in the main package are actually
> devel files.

There are no files installed into %_datadir/lv2

In case you refer to %_libdir/lv2, notice the recommendation in the README.
Comment 2 Orcan Ogetbil 2009-03-16 09:53:17 EDT
(In reply to comment #1)
> > I believe that this package should be noarch
> 
> That would make it necessary to alter/redefine the LV2 path, which by default
> points into %_libdir
> 

Yes, but this is the only modification needed.

> 
> > The files %{_datadir}/lv2 that are in the main package are actually
> > devel files.
> 
> There are no files installed into %_datadir/lv2
> 
> In case you refer to %_libdir/lv2, notice the recommendation in the README.  

Yes, well after altering/redefining the LV2 path it will be %_datadir/lv2 . Sorry for not being clear.

But I think I made a mistake here. Those files may be needed during runtime. So please ignore this comment of mine.
Comment 3 Michael Schwendt 2009-03-16 10:59:51 EDT
Where do you store LV2 plugins then if not in LV2 path?
Comment 4 Orcan Ogetbil 2009-03-16 11:37:08 EDT
arch specific plugins? oh, I see your point. Then this package needs to be arch-specific. Sorry my bad.

I'm changing the bug title to reflect the remaining issues
Comment 5 Orcan Ogetbil 2009-03-30 18:32:46 EDT
It's been two weeks since this bug was opened. I tried to contact the maintainer via email but got no reply. We need an F-10 build of lv2 to build slv2.
Comment 6 Anthony Green 2009-03-30 19:25:40 EDT
It appears that I don't have time to do this anymore.  I'm happy to give up maintainership if you'd like to pick it up.

AG
Comment 7 Orcan Ogetbil 2009-03-30 19:33:37 EDT
Sure Anthony, sorry to hear that. You've done great contributions to audio production packages in Fedora. I hope everything is going fine with you.

Could you approve my pkgdb requests then?

https://admin.fedoraproject.org/pkgdb/packages/name/lv2core
Comment 8 Anthony Green 2009-03-30 19:52:35 EDT
Thanks for asking, but everything is great!  It's just that Fedora work has dropped a little in my priorities recently.   pkgdb requests are approved.

AG
Comment 9 Fedora Update System 2009-03-30 21:46:52 EDT
lv2core-3.0-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/lv2core-3.0-2.fc10
Comment 10 Orcan Ogetbil 2009-04-01 10:01:56 EDT
I updated slv2 and built it in both rawhide and F-10. Closing the bug.
Comment 11 Orcan Ogetbil 2009-04-01 10:02:26 EDT
I meant lv2core. Well, I built slv2 too :)
Comment 12 Fedora Update System 2009-04-08 10:07:04 EDT
lv2core-3.0-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/lv2core-3.0-3.fc10
Comment 13 Fedora Update System 2009-04-13 15:42:47 EDT
lv2core-3.0-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.