Bug 4904 - default /etc/zshenv doesn't find grep in zsh-3.0.5-13
Summary: default /etc/zshenv doesn't find grep in zsh-3.0.5-13
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: zsh   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-04 12:02 UTC by Pekka Pietikäinen
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-18 21:18:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Pietikäinen 1999-09-04 12:02:22 UTC
connecting (pp):~ >su
Password:
/etc/zshenv: command not found: grep [16]
/etc/zshenv: command not found: grep [17]

The problem is caused by zshenv having

if [ `id -u` -eq 0 ]; then
  path=(/sbin /usr/sbin)
fi

in it and after that trying to use grep (which is in /bin).

Comment 1 David Lawrence 1999-09-18 21:18:59 UTC
Fixed in zsh-3.0.5-14


Note You need to log in before you can comment on or make changes to this bug.