Bug 490451 - klamav update doesn't work
klamav update doesn't work
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: klamav (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Andy Shevchenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-16 10:34 EDT by Knut-Håvard Aksnes
Modified: 2009-03-31 16:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.46-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 16:31:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut-Håvard Aksnes 2009-03-16 10:34:12 EDT
Description of problem:
Auto uppdate of klamav doesn't work if the qt4 development environment are installed.

Version-Release number of selected component (if applicable):
klamav-0.44-3.fc10.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Open update tab in klamav
2. Click Upgrade Klamav now
3. Follow instructions for use of the upgrade wizard
  
Actual results:
The compilation fails due to version conflict between kde and qt

Expected results:
Installation of an upgraded version of klamav.

Additional info:
This auto update function should either work or be disabled in the distribution. The best would probably be if it works, a very fast upgrade option might be needed due to the applications nature. An easy workaround would be to make new versions of klamav available via yum upgrade fairly quick. It is difficult for users not following klamav closely to decide if an upgrade important or not.
Comment 1 Andy Shevchenko 2009-03-19 05:24:45 EDT
You are right about update scheduling. So, In next release I'll switch off this menu.
Comment 2 Kevin Kofler 2009-03-19 13:26:06 EDT
An auto-update feature which compiles the software from source is really a bad idea to ship in a distribution, so I agree that switching this off is the best solution.
Comment 3 Fedora Update System 2009-03-19 17:48:56 EDT
klamav-0.46-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/klamav-0.46-2.fc10
Comment 4 Fedora Update System 2009-03-19 17:49:05 EDT
klamav-0.46-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/klamav-0.46-2.fc9
Comment 5 Fedora Update System 2009-03-20 14:33:00 EDT
klamav-0.46-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update klamav'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-2863
Comment 6 Fedora Update System 2009-03-20 14:36:20 EDT
klamav-0.46-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update klamav'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2871
Comment 7 Fedora Update System 2009-03-31 16:31:29 EDT
klamav-0.46-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-03-31 16:36:52 EDT
klamav-0.46-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.