Bug 490460 - liveinst not starting in graphical mode
liveinst not starting in graphical mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libXau (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
NEEDSRETESTING
: Reopened
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-03-16 11:06 EDT by Sebastian Vahl
Modified: 2014-06-18 05:11 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 18:16:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2009-03-16 11:06:18 EDT
Description of problem:
When trying to start liveinst through it's menu icon I receive this error in my .xsession-errors:

kdeinit4: preparing to launch /usr/bin/liveinst
  0 logical volume(s) in volume group "Volg1" now active
15:33:22 Starting graphical installation...
No protocol specified
15:33:23 Exception starting GUI installer: could not open display
15:33:23 GUI installer startup failed, falling back to text mode.
TERM environment variable needs set.



Version-Release number of selected component (if applicable):
anaconda-11.5.0.30-1.x86_64

How reproducible:
ever

Steps to Reproduce:
1. create recent KDE live image
2. boot this image
3. start liveinst through the menu or desktop icon
  
Actual results:
liveinst fails to start

Expected results:
liveinst starts 

Additional info:
I've also tried to start "liveinst --graphical" in a terminal. One time it succeeds to start (and the it was also possible to start it through the desktop icon). The other 5-6 times it fails and started the text mode instead. I wasn't able to find out why it started this one time only.
Comment 1 Jeremy Katz 2009-03-16 15:41:11 EDT
If you su to root in a terminal, can you (eg) launch an xterm?
Comment 2 Sebastian Vahl 2009-03-16 17:15:54 EDT
Mhh, I can't:

[root@work liveuser]# xterm
No protocol specified
Warning: This program is an suid-root program or is being run by the 
root user.
The full text of the error or warning message cannot be safely formatted
in this environment. You may get a more descriptive message by running 
the
program as a non-root user or by removing the suid bit on the 
executable.
xterm Xt error: Can't open display: %s
Comment 3 Jeremy Katz 2009-03-16 17:28:18 EDT
Happening also with the desktop live image.

Reassigning to libXau as it changed last week and sounds like it could suspiciously be related.  The actual component to be fixed, though, might be that pam_xauth needs updating for the libXau changes so also cc'ing tmraz
Comment 4 Tomas Mraz 2009-03-17 03:54:15 EDT
pam_xauth does not call libXau directly. It execs xauth to copy the cookie.
Comment 5 Jeremy Katz 2009-03-17 15:11:11 EDT
Adam -- any thoughts?
Comment 6 Adam Jackson 2009-03-18 21:35:30 EDT
So, that change was put in to work around networkmanager enthusiastically changing the hostname out from under you.  But I think the change implements the wrong thing; it should really only do the sloppy (non-hostname-sentitive) match if it couldn't find a strict match.

Maybe.  Need to think about it more.  Reverted in 1.0.4-5 at any rate.
Comment 7 Jeremy Katz 2009-03-21 18:16:37 EDT
Tested with the new bits on Friday and installs work again.  Thanks ajax
Comment 8 Sebastian Vahl 2009-03-23 08:14:05 EDT
Cannot confirm this with a KDE live image. I'm still unable to start graphical apps as root.

The changes from friday were mostly gdm related. So does kdm also needs to be fixed?
Comment 9 Jeremy Katz 2009-03-23 09:05:55 EDT
The change was in libXau, not gdm.  So it should be applicable for both.  Does your image have libXau-1.0.4-5?
Comment 10 Jeremy Katz 2009-03-23 09:52:19 EDT
Just built a kde live image and it worked fine (with libXau-1.0.4-5)
Comment 11 Sebastian Vahl 2009-03-23 09:59:54 EDT
Yes, libXau-1.0.4-5 is included (for all included packages see: http://www.deadbabylon.de/fedora/livecd/packagelists/f11/long-F11-KDE-053-i686.txt). 

I've also created a Desktop spin and there it works, but not on the kde one.
Comment 12 Sebastian Vahl 2009-03-23 10:54:44 EDT
Mhh. Strange. It does work if I boot from a cd. It does not work If I boot from a local partition or an usb stick. But the same usb stick is working fine on my EEE.
Comment 13 Adam Williamson 2009-04-22 13:07:08 EDT
sebastian, can you check this again? it's on the preview release blocker list. you could test with the Snapshot image, I think.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Sebastian Vahl 2009-04-22 18:16:39 EDT
Sure, sorry for the delay: It's fixed now (tested with a live image from yesterday).

Note You need to log in before you can comment on or make changes to this bug.