Bug 490475 - API - auth.login() - provide better error messages on exception
API - auth.login() - provide better error messages on exception
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: API (Show other bugs)
0.5
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Jesus M. Rodriguez
:
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2009-03-16 12:25 EDT by Brad Buckingham
Modified: 2009-09-17 03:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:11:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Buckingham 2009-03-16 12:25:20 EDT
Description of problem:

Update XMLRRPC API auth.login() to return error messages that are consistent with the errors displayed to them if logging in through the UI.


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. invoke auth.login() with a user that is 
   a. deactivate or 
   b. with an invalid login or password
  
Actual results:
1. a. account.disabled
1. b. error.invalid_login

Expected results:
1. a. "Your account has been deactivated."
1. b. "Either the password or username is incorrect."

Additional info:
Comment 1 Brad Buckingham 2009-03-16 12:35:06 EDT
git commit: 775a37377feadedd46221a615586fd9145f148e1

Updated the API to use the localized error text that a user gets if they attempted a failed login scenario from the UI.  

The new output to a failed attempt to login via API looks like:


xmlrpclib.Fault: <Fault 2950: 'redstone.xmlrpc.XmlRpcFault: Either the password or username is incorrect.'>

xmlrpclib.Fault: <Fault 2950: 'redstone.xmlrpc.XmlRpcFault: Your account has been deactivated.'>
Comment 2 Brad Buckingham 2009-03-23 16:28:24 EDT
mass move to ON_QA
Comment 3 Brandon Perkins 2009-03-23 21:20:55 EDT
Removing bug 490475 blocks bug 488488.
Comment 4 Jesus M. Rodriguez 2009-04-14 10:13:34 EDT
Spacewalk 0.5 released.
Comment 5 Miroslav Suchý 2009-09-17 03:11:16 EDT
Spacewalk 0.5 has been released for long time ago.

Note You need to log in before you can comment on or make changes to this bug.