Bug 490484 - Pressing Alt -< does not give '|' (bar) as expected.
Pressing Alt -< does not give '|' (bar) as expected.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xkeyboard-config (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-16 13:03 EDT by Pawel Salek
Modified: 2009-05-20 20:02 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.4-8.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 20:02:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pawel Salek 2009-03-16 13:03:55 EDT
Description of problem:
I have Dell Latitude D630 hardware with Swedish keyboard. The keyboard has a key  in a left lower corner with three symbols: <, >, and |. Unfortunately, pressing Alt-that-key does not produce '|'. The problem is fixed by adding one line to /usr/share/X11/xkb/symbols/se

Version-Release number of selected component (if applicable):
xkeyboard-config-1.4-6.fc10.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Press Alt-< 
  
Actual results:
Nothing is produced.

Expected results:
'|' character should appear.

Additional info:
I have worked around the problem by adding following line to /usr/share/X11/xkb/symbols/se
 xkb_symbols "se" {
  ...
+    key <LSGT>  { [  less,       greater,          bar,          bar ] };
     include "kpdl(comma)"

     include "level3(ralt_switch)"
};

I am not sure whether this is the best solution but it works for me.
Comment 1 Peter Hutterer 2009-04-27 23:18:40 EDT
Thanks. I sent the patch to the upstream maintainer, waiting for his feedback.
Comment 2 Fedora Update System 2009-04-28 18:51:36 EDT
xkeyboard-config-1.4-8.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xkeyboard-config-1.4-8.fc10
Comment 3 Fedora Update System 2009-05-02 12:34:46 EDT
xkeyboard-config-1.4-8.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xkeyboard-config'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4152
Comment 4 Fedora Update System 2009-05-20 20:02:28 EDT
xkeyboard-config-1.4-8.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.