Bug 490494 - nouveau on gf 6600gt results in GPU lockup
nouveau on gf 6600gt results in GPU lockup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-16 13:42 EDT by Jarod Wilson
Modified: 2009-08-07 18:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 488342
Environment:
Last Closed: 2009-08-07 17:13:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg snippet from load of drm w/debug=1 (106.65 KB, text/plain)
2009-03-16 13:51 EDT, Jarod Wilson
no flags Details

  None (edit)
Description Jarod Wilson 2009-03-16 13:42:50 EDT
+++ This bug was initially created as a clone of Bug #488342 +++

Description of problem:
If I try to start up X on the PCIe GeForce 6600GT in one of my x86_64 boxes here using the nouveau driver

[...]

Version-Release number of selected component (if applicable):
# uname -r
2.6.29-0.237.rc7.git4.fc11.x86_64
# rpm -q xorg-x11-drv-nouveau
xorg-x11-drv-nouveau-0.0.12-10.20090310git8f9a580.fc11.x86_64

Additional info:
# lspci -v -s 05:00.0
05:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600 GT] (rev a2) (prog-if 00 [VGA controller])
	Subsystem: eVga.com. Corp. Device c420
	Flags: bus master, fast devsel, latency 0, IRQ 28
	Memory at f8000000 (32-bit, non-prefetchable) [size=64M]
	Memory at d0000000 (64-bit, prefetchable) [size=128M]
	Memory at fd000000 (64-bit, non-prefetchable) [size=16M]
	Expansion ROM at feae0000 [disabled] [size=128K]
	Capabilities: [60] Power Management version 2
	Capabilities: [68] MSI: Mask- 64bit+ Count=1/1 Enable-
	Capabilities: [78] Express Endpoint, MSI 00
	Kernel driver in use: nouveau
	Kernel modules: nouveau, nvidiafb
[...]

--- Additional comment from bskeggs@redhat.com on 2009-03-06 18:34:53 EDT ---

Ok, I'll mark this as resolved then :)

(In reply to comment #6)
> No more oopses for me, so that's a distinct improvement, but still no X. The
> following shows up in dmesg:
> 
> [drm] Allocating FIFO number 0
> [drm] nouveau_fifo_alloc: initialised FIFO 0
> [drm] PFIFO_DMA_PUSHER - Ch 0
>
> --snip--
> 
> (can attach full log file if so desired)  
Thank you, a full dmesg log would be very useful.  It'd be even more useful if you were able to load the drm module with debug=1 :)  When you do so can you please file a new bug, as the original issue mentioned here is fixed.

--------------------------------------------------------------------

Xorg.0.log says:

Fatal server error:
Detected GPU lockup

While dmesg says:

[drm] Allocating FIFO number 0
[drm] nouveau_fifo_alloc: initialised FIFO 0
[drm] PFIFO_DMA_PUSHER - Ch 0
[drm] Allocating FIFO number 1
[drm] nouveau_fifo_alloc: initialised FIFO 1
[drm] PFIFO_DMA_PUSHER - Ch 0
[drm] PFIFO_DMA_PUSHER - Ch 0
[drm] PFIFO_DMA_PUSHER - Ch 0
[drm] PFIFO_DMA_PUSHER - Ch 0
[drm] PFIFO_DMA_PUSHER - Ch 0
[drm] PFIFO_DMA_PUSHER - Ch 0
[drm] PFIFO_DMA_PUSHER - Ch 0
[drm] nouveau_fifo_free: freeing fifo 1
[drm] PFIFO_DMA_PUSHER - Ch 0
[drm] nouveau_fifo_free: freeing fifo 0
[drm:nouveau_fifo_free] *ERROR* Failed to idle channel 0 before destroy.Prepare for strangeness..
[drm] PFIFO_DMA_PUSHER - Ch 0


Full dmesg w/debug=1 for the drm module coming shortly...
Comment 1 Jarod Wilson 2009-03-16 13:51:25 EDT
Created attachment 335384 [details]
dmesg snippet from load of drm w/debug=1
Comment 2 Jarod Wilson 2009-03-26 15:26:23 EDT
nb: prior stuff was from a dual-head setup, just tried single-head to see if it made things any better. Nope, same failure mode..
Comment 3 Ben Skeggs 2009-05-26 19:05:30 EDT
Do you still see this with the latest versions of everything?  There was a bug fixed a while back this could've been, though I wouldn't have expected it to be triggered with -10, worth a try though.

New dmesg and /var/log/Xorg.0.log would be useful :)

Thanks!
Comment 4 Bug Zapper 2009-06-09 08:16:52 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Jarod Wilson 2009-08-07 11:44:32 EDT
Finally got the card freed up again (was in my main workstation being used with a... different driver...). Its now in a test box, which I've updated to rawhide. Looks good initially, kernel mode setting is doing the right thing, but some sort of misc. other rawhide breakage "fsck: Unable to allocate memory for fsck_path" is currently preventing me from getting any further...
Comment 6 Jarod Wilson 2009-08-07 14:17:30 EDT
Got past the fsck thing, but X is segfaulting on me now. It happens with both the nouveau driver and the vesa driver though, so its probably some other rawhide fail, not nouveau's fault.
Comment 7 Adam Williamson 2009-08-07 16:24:24 EDT
See http://rawhidewatch.wordpress.com/2009/08/06/rawhide-x-crashes-on-startup/ , but someone did post on test-list that even -127 didn't work with them for nouveau. It would be helpful to have a yea or nay on that, actually. I don't want to do it because this is my main system, so if I reboot and X fails to work, I am rather stuffed from a 'getting work done' perspective :)

there is also a newer xorg-x11-drv-nouveau in koji than in rawhide currently, it may be worthwhile to update that too.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Jarod Wilson 2009-08-07 16:38:45 EDT
I was already on xorg-x11-server-Xorg-1.6.99-28, but just pulled -30 out of koji, along with a slightly newer xorg-x11-drv-nouveau. I'm finally looking at X up and running on this card w/nouveau for the first time ever. :) (with dual monitors, no less)
Comment 9 Jarod Wilson 2009-08-07 17:13:13 EDT
Going to close this one out, card seems to be behaving quite well now.
Comment 10 Adam Williamson 2009-08-07 17:39:07 EDT
great! this got auto-changed to f11 as f11 came out while it was open. do you want to hold it open and see if ben can backport the fixes to an f11 update, or change it back to rawhide and close it?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Jarod Wilson 2009-08-07 18:01:24 EDT
Hm... rawhide nouveau has seen a LOT of changes, from what I recall, so this may not be particularly easy to backport... I'm perfectly happy with it being fixed in rawhide, and perhaps once 2.6.31 is out, we get an F11 kernel w/these fixes too.

Note You need to log in before you can comment on or make changes to this bug.