Bug 490516 - evolution-data-server update fails due to missing deps.
Summary: evolution-data-server update fails due to missing deps.
Keywords:
Status: CLOSED DUPLICATE of bug 491916
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-metadata-parser
Version: 5.3
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: James Antill
QA Contact: BaseOS QE Security Team
URL:
Whiteboard:
: 495328 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-03-16 19:21 UTC by Phil Shen
Modified: 2014-01-21 06:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-04-14 16:10:59 UTC


Attachments (Terms of Use)

Description Phil Shen 2009-03-16 19:21:15 UTC
Description of problem:
[root@library html]# yum update
Loaded plugins: rhnplugin, security
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package evolution-data-server-devel.i386 0:1.12.3-10.el5_3.3 set to be updated
---> Package evolution-data-server.i386 0:1.12.3-10.el5_3.3 set to be updated
--> Processing Dependency: libebook-1.2.so.9 for package: gnome-panel
--> Processing Dependency: libebook-1.2.so.9 for package: control-center
--> Processing Dependency: libebook-1.2.so.9 for package: bug-buddy
--> Processing Dependency: libecal-1.2.so.7 for package: gnome-panel
--> Processing Dependency: libedataserver-1.2.so.7 for package: gnome-panel
--> Processing Dependency: libedataserver-1.2.so.7 for package: control-center
--> Processing Dependency: libedataserver-1.2.so.7 for package: bug-buddy
--> Processing Dependency: libedataserverui-1.2.so.8 for package: gnome-panel
--> Processing Dependency: evolution-data-server >= 1.1.4 for package: gnome-panel
--> Finished Dependency Resolution
gnome-panel-2.16.1-7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libecal-1.2.so.7 is needed by package gnome-panel-2.16.1-7.el5.i386 (installed)
1:control-center-2.16.0-16.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libedataserver-1.2.so.7 is needed by package 1:control-center-2.16.0-16.el5.i386 (installed)
1:bug-buddy-2.16.0-2.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libebook-1.2.so.9 is needed by package 1:bug-buddy-2.16.0-2.el5.i386 (installed)
gnome-panel-2.16.1-7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libedataserver-1.2.so.7 is needed by package gnome-panel-2.16.1-7.el5.i386 (installed)
gnome-panel-2.16.1-7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libebook-1.2.so.9 is needed by package gnome-panel-2.16.1-7.el5.i386 (installed)
gnome-panel-2.16.1-7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libedataserverui-1.2.so.8 is needed by package gnome-panel-2.16.1-7.el5.i386 (installed)
gnome-panel-2.16.1-7.el5.i386 from installed has depsolving problems
  --> Missing Dependency: evolution-data-server >= 1.1.4 is needed by package gnome-panel-2.16.1-7.el5.i386 (installed)
1:bug-buddy-2.16.0-2.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libedataserver-1.2.so.7 is needed by package 1:bug-buddy-2.16.0-2.el5.i386 (installed)
1:control-center-2.16.0-16.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libebook-1.2.so.9 is needed by package 1:control-center-2.16.0-16.el5.i386 (installed)
Error: Missing Dependency: libecal-1.2.so.7 is needed by package gnome-panel-2.16.1-7.el5.i386 (installed)
Error: Missing Dependency: libebook-1.2.so.9 is needed by package 1:control-center-2.16.0-16.el5.i386 (installed)
Error: Missing Dependency: libedataserver-1.2.so.7 is needed by package 1:bug-buddy-2.16.0-2.el5.i386 (installed)
Error: Missing Dependency: libebook-1.2.so.9 is needed by package gnome-panel-2.16.1-7.el5.i386 (installed)
Error: Missing Dependency: libedataserver-1.2.so.7 is needed by package 1:control-center-2.16.0-16.el5.i386 (installed)
Error: Missing Dependency: libebook-1.2.so.9 is needed by package 1:bug-buddy-2.16.0-2.el5.i386 (installed)
Error: Missing Dependency: libedataserverui-1.2.so.8 is needed by package gnome-panel-2.16.1-7.el5.i386 (installed)
Error: Missing Dependency: evolution-data-server >= 1.1.4 is needed by package gnome-panel-2.16.1-7.el5.i386 (installed)
Error: Missing Dependency: libedataserver-1.2.so.7 is needed by package gnome-panel-2.16.1-7.el5.i386 (installed)
[root@library html]#


Version-Release number of selected component (if applicable):


How reproducible:
run yum update

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Scott Weigand 2009-03-17 13:53:09 UTC
I had this same problem. I removed (all via yum) evolution-data-server, which removes gnome-session & gnome-applet and reinstalled evolution-data-server & gnome-session & gnome-applet. 

It is crude, but got the job done. This is on a 5.3 with all updates.

Comment 6 Jose Plans 2009-04-14 16:10:59 UTC

*** This bug has been marked as a duplicate of bug 491916 ***

Comment 7 James Antill 2009-04-14 21:06:47 UTC
*** Bug 495328 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.