Bug 490518 - When multiple NICs present, prompts twice for NIC to use (method= and updates=)
When multiple NICs present, prompts twice for NIC to use (method= and updates=)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-03-16 15:40 EDT by James Laska
Modified: 2013-09-02 02:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-30 17:29:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (3.98 KB, text/plain)
2009-03-16 15:40 EDT, James Laska
no flags Details
anaconda-is_nm_connected.patch (2.21 KB, patch)
2009-04-21 21:24 EDT, David Cantrell
no flags Details | Diff
0002-Configure-network-in-kickstartNetworkUp-iff-NM-is.patch (2.30 KB, patch)
2009-04-21 21:33 EDT, David Cantrell
no flags Details | Diff

  None (edit)
Description James Laska 2009-03-16 15:40:14 EDT
Created attachment 335415 [details]
anaconda.log

Description of problem:

Boot rawhide installer with "method=http://... updates=http://..."

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Enter lang, keymap
2. When prompted, select correct NIC 
  
Actual results:

After downloading the install.img, I am prompted again for the NIC to use to grab the updates.img

            +----------------+ Networking Device +----------------+
            |                                                     |
            | You have multiple network devices on this system.   |
            | Which would you like to install through?            |
            |                                                     |
            |   eth0 - Ethernet device eth0 - 00:11:25:7e:28:64   |
            |   eth1 - Ethernet device eth1 - 00:0d:60:b9:6b:c8   |
            |   eth2 - Ethernet device eth2 - 00:11:25:7e:28:65   |
            |                                                     |
            |    +----+         +----------+         +------+     |
            |    | OK |         | Identify |         | Back |     |
            |    +----+         +----------+         +------+     |
            |                                                     |
            |                                                     |
            +-----------------------------------------------------+

Expected results:

I wasn't expecting to be prompted twice, I assumed that it would use my first selection entered to get the install.img.

Additional info:
Comment 1 Tristan Santore 2009-04-05 14:44:19 EDT
I believe this is done on purpose, so you can specify a different location for your updates.img. Have you specified a ksdevice= ?
Comment 2 David Cantrell 2009-04-21 20:20:58 EDT
James,

This is happening in the kickstartNetworkUp() function, which is called because you are supplying a network location for updates=

The kickstartNetworkUp() function was not checking to see if we had an active network connection and always prompting you to choose and interface and reconfigure it.  I've added a check for an active connection in kickstartNetworkUp(), so in this particular case you should skip over it, but the functionality required for other uses of kickstartNetworkUp() should continue to function as usual.

I'm attaching a ppc initrd.img that I'd like you to try as soon as possible.  I've tested things here and I think it's working, but then again I only have one NIC in my test box (other one stopped working, had to remove it).
Comment 3 David Cantrell 2009-04-21 21:22:36 EDT
Well, I lied.  I can't make a new netboot image for ppc32 or ppc64 because I don't have a ppc system at my disposal.  So I built a new ramdisk.image.gz that you can then use to construct your own ppc32.img or ppc64.img file.

Download the ramdisk:
http://dcantrel.fedorapeople.org/ramdisk.image.gz

Pick your kernel:
(for 32-bit ppc):
http://download.fedora.redhat.com/pub/fedora/linux/development/ppc/os/ppc/ppc32/vmlinuz
(for 64-bit ppc):
http://download.fedora.redhat.com/pub/fedora/linux/development/ppc/os/ppc/ppc64/vmlinuz

Make sure ppc64-utils is installed.  Run this command:

mkzimage vmlinuz no no ramdisk.image.gz /usr/share/ppc64-utils/zImage.stub netboot.img

Where 'vmlinuz' and 'ramdisk.image.gz' are in the current directory.  The 'netboot.img' file is the new network boot image you can try.

Let me know if it at least stops prompting you twice for the NIC in loader.  If it gets to stage 2, that's good, but I only really care about the NIC choice in loader for this test.
Comment 4 David Cantrell 2009-04-21 21:24:20 EDT
Created attachment 340659 [details]
anaconda-is_nm_connected.patch
Comment 5 David Cantrell 2009-04-21 21:33:51 EDT
Created attachment 340660 [details]
0002-Configure-network-in-kickstartNetworkUp-iff-NM-is.patch
Comment 6 James Laska 2009-04-22 07:42:45 EDT
Thanks David, I should note that this is also fairly easy for me to test in a virt setup on a x86_64 system nearby.  Is there information I can gather for you on those platforms?
Comment 7 David Cantrell 2009-04-28 16:00:47 EDT
If you can test on x86_64, that's easier for me.  I can generate a test initrd.img.  I want to see if you get prompted for the NIC selection twice or if this patch fixes it so you are only prompted once.

Let me generate a new initrd.img for x86_64 for you to test.
Comment 8 David Cantrell 2009-04-30 17:29:49 EDT
Fix will be in anaconda-11.5.0.49-1.fc11.

Note You need to log in before you can comment on or make changes to this bug.